Microsoft Excel

Herbers Excel/VBA-Archiv

Suchfunktion in Excel

    Betrifft: Suchfunktion in Excel von: Matias
    Geschrieben am: 28.08.2003 23:03:50

    Hallo zusammen

    ich sitze an meiner Diplomarbeit und muss ein Excelprogramm erweitern
    dass OHNE Makros laufen muss !!
    Mein Problem sieht so aus:

    Ich habe in Tabelle 1 Zelle A1 einen numerischen Wert
    Diesr Wert soll in Tabelle 2 Spalte A1:A100 gesucht werden.

    Angenommen dieser Wert wird in Tabelle 2 Zelle A58 gefunden,
    nun soll der nebenstehende Wert (also aus Tabelle 2 Zelle B58) in
    Tabelle 1 Zelle B1 geschrieben werden,

    und falls er nicht gefunden wird sollte in Tabelle 1 Zelle B1 einfach gar nichts stehen.

    Wer weiss eine Lösung ? Scon mal tausend dank im voraus an alle die mit
    mir mittüfteln !!!

    Matthias

      


    Betrifft: INDEX und VERGLEICH von: Boris
    Geschrieben am: 28.08.2003 23:17:15

    Hi Matthias,

    aus der Hand - in Tabelle1, B1:

    =WENN(ZÄHLENWENN(Tabelle2!A:A;A1);INDEX(Tabelle2!B:B;VERGLEICH(A1;Tabelle2!A:A;0));"")

    Grüße Boris


      


    Betrifft: AW: INDEX und VERGLEICH von: matias
    Geschrieben am: 28.08.2003 23:36:40

    Vielen vielen dank Boris
    hast was gut !!!!


      


    Betrifft: AW: Suchfunktion in Excel von: Franz Pölt
    Geschrieben am: 28.08.2003 23:19:18

    Hallo Matthias,

    Formel für Tabelle 1 - B1:

    =WENN(ISTFEHLER(SVERWEIS(A1;Tabelle2!A1:B100;2;FALSCH));"";SVERWEIS(A1;Tabelle2!A1:B100;2;FALSCH))

    Servus aus dem Salzkammergut
    Franz


      


    Betrifft: FALSCH brennt mir immer so in den Augen... von: Boris
    Geschrieben am: 28.08.2003 23:21:59

    Hi Franz,

    ...du als wirklich klasse "Formulierer":
    Null oder nix - aber bitte nicht FALSCH...;-)

    Grüße Boris


      


    Betrifft: AW: FALSCH brennt mir immer so in den Augen... von: Franz Pölt
    Geschrieben am: 29.08.2003 01:14:55

    Hallo Boris,

    ich wollte doch den armen Matthias nicht mit solchen Formeln verwirren - wo er eh schon mitten in der Diplomarbeit steckt ;-)

    {=WENN(MAX((Tabelle2!A1:A100=A1)*1);SVERWEIS(A1;Tabelle2!A1:B100;2;FALSCH);"")}

    Servus aus dem Salzkammergut
    Franz


      


    Betrifft: AW: Suchfunktion in Excel von: WalterK
    Geschrieben am: 28.08.2003 23:19:40

    Hallo

    Formel in B1:
    =WENN(ODER(ISTFEHLER(SVERWEIS(A1;Tabelle2!A1:B100;2;0));SVERWEIS(A1;Tabelle2!A1:B100;2;0)=0);"";SVERWEIS(A1;Tabelle2!A1:B100;2;0))

    Servus, Walter