Microsoft Excel

Herbers Excel/VBA-Archiv

#NV umgehen?

    Betrifft: #NV umgehen? von: Sven
    Geschrieben am: 29.08.2003 21:43:19

    Hallo Excelianer,

    wie bekomme ich eine Endformel dazu, auch mit leeren Feldern zu rechnen, wenn die Felder je nach sverweis bzw. wenn- Funktion leer oder gefüllt sind?

    Gruß Sven

      


    Betrifft: AW: #NV umgehen? von: Bertram
    Geschrieben am: 29.08.2003 21:49:34

    Hallo Sven,

    hast du mal ein Beispiel?

    Gruß
    Bertram


      


    Betrifft: AW: #NV umgehen? von: Sven
    Geschrieben am: 29.08.2003 22:03:53

    Hallo Bertram,

    A1:10€ B1:Gültigkeitsliste:Auto:ja oder nein C1:=WENN B1=ja DANN 5 sonst 0 D1:+A1+C1
    D1 ist bei mir #NV, wenn C1 leer.

    Genauso ist es mit einem sverweis:schreibe ich die Bedingung in Zelle B1, kommt in C1 ein Wert und die Formel in D1 funktioniert, lasse ich die Zelle B1 leer, steht auch in C1 nichts und wieder #NV.

    Hoffentlich ist es verständlich erklärt.

    Gruß Sven


      


    Betrifft: AW: #NV umgehen? von: olibar
    Geschrieben am: 29.08.2003 22:17:32

    Versuch es mal mit: wenn(istfehler(sverweis(x;y;z);"";sverweis(x;y;z))), dadurch wird der "falsche" sverweis in eine leere Zelle gewandelt, und dur kannst mit dieser Zelle weiterarbeiten

    Gru

    olibar


      


    Betrifft: AW: #NV umgehen? von: Sven
    Geschrieben am: 29.08.2003 22:34:22

    Hallo Olibar,

    habe jetzt rumgedoktort, aber ich krieg es nicht hin. In welche Zelle soll ich Deine Formel integrieren?

    Gruß Sven


      


    Betrifft: AW: #NV umgehen? von: olibar
    Geschrieben am: 30.08.2003 14:49:28

    Hallo Sven,

    hatte bisher keine Zeit, hier mal reinzuschauen, daher erst jetzt meine Reaktion. Falls Du noch nicht weitergekommen bist, versuch ich jetzt mal, das ganze zu erklären und hoffe, Deine Frage nicht falsch verstanden zu haben.

    Angenommen Du hast eine Tabelle mit Daten (Datenbank) in Tabelle1 gespeichert. Spalte A soll dabei sagen wir mal die Artikelgruppe beinhalten, Spalte B die Artikelnummer, Spalte C die Bezeichnung, Spalte D den Einzelpreis.

    Du willst jetzt eine Auswertung machen in Tabelle2 und hast nur die Artikelnummern in der Spalte A und die dazugehörigen Lieferanten in Spalte B zur Verfügung. Ziel Deiner Auswertung ist die Gesamtsumme der Artikelnummern eines Lieferanten. Also braucht Du zunächst den Sverweis auf die Tabelle1. In der Zelle C1 gibst Du ein: =SVERWEIS(A:A;Tabelle1!B:D;3;FALSCH). Dann ziehst Du die Formel über den gesamten Datenbereich in Tabelle2 herunter. Das Ergebnis wird der Einzelpreis des Artikels aus der Tabelle1 sein, den Du nun dem jeweiligen Lieferanten zugeordnet hast. Kommt es nun vor, daß Du einen Wert in Tabelle 2 hast, der in Tabelle1 nicht vorhanden ist, gibt die Formel den Fehlerwert #NV aus, damit kannst Du die Zahlen in der Spalte C nicht mehr weiterberechnen, da Excel immer wieder den Fehlerwert #NV ausgibt. Mit der Formel =WENN(ISTFEHLER(SVERWEIS(A:A;Tabelle1!B:D;3;FALSCH));"";SVERWEIS(A:A;Tabelle1!B:D;3;FALSCH)) in Zelle C1 erreichst Du, daß in Zelle C1 im eben genannten Fall die Zelle leer ist, und Du dann alle Werte der Spalte C berechnen kannst. Ebenso kannst Du statt "" eine 0 angeben.

    Wenn Du nun einen beliebigen Lieferanten in Spalte B filterst, erhältst Du mit =TEILERGEBNIS(9;C:C) in Zelle D1 das gewünschte Ergebnis.

    Versuch jetzt, diese Beschreibung auf Dein Problem anzuwenden. Viel Spaß dabei.

    Ich hoffe Du kommst weiter. Da ich heute abend eingeladen bin, werde ich frühestens morgen wieder hier reinschauen.

    Gruß

    Oliver


      


    Betrifft: AW: #NV umgehen? von: olibar
    Geschrieben am: 30.08.2003 15:05:18

    ...habe mir gerade Deine Musterdatei heruntergeladen. Nach meiner Methode lautet die Formel in D2: =WENN(ISTFEHLER(SVERWEIS(C2;B5:C8;2;FALSCH));0;(SVERWEIS(C2;B5:C8;2;FALSCH))). Damit erreichst Du jetzt zwar, daß Dein Preis in H2 völlig blödsinnig ist (200,- €), aber das Problem löst Du zum Bsp. so: Formel in H2: =WENN(D2="";"kein Lieferort, Lieferung nicht möglich!";+A2+D2*B2+E2*B2+F2-G2). Hast Du in Zelle D1 folgende Formel: =WENN(ISTFEHLER(SVERWEIS(C2;B5:C8;2;FALSCH));"";(SVERWEIS(C2;B5:C8;2;FALSCH))), muß die Formel in H1 lauten: =WENN(D2="";"kein Lieferort, Lieferung nicht möglich!";+A2+D2*B2+E2*B2+F2-G2)

    Der Unterschied: "" statt 0 in der WENN-Bedingung.

    Gruß

    Oliver

    P.S. melde Dich bitte kurz, wenn es klappt


      


    Betrifft: AW: #NV umgehen? von: Bertram
    Geschrieben am: 29.08.2003 22:31:13

    Hallo Sven,

    wenn ich nur mal auf das eingehe

    "A1:10€ B1:Gültigkeitsliste:Auto:ja oder nein C1:=WENN B1=ja DANN 5 sonst 0 D1:+A1+C1
    D1 ist bei mir #NV, wenn C1 leer."

    dann verstehe ich nicht wie C1 jemals leer sein kann. Bei mir ist es zumindest 0.

    Kannst du mir das näher erklären (falls dir Olibar nicht helfen konnte)?

    Gruß
    Bertram


      


    Betrifft: AW: #NV umgehen? von: Sven
    Geschrieben am: 29.08.2003 22:48:09

    Hallo Bertram,

    Du hast natürlich recht, ich habe eine Musterdatei in den Server geladen.

    Gruß Sven


      


    Betrifft: AW: #NV umgehen? von: Sven
    Geschrieben am: 29.08.2003 22:49:36

    Link ist verloren gegangen.

    https://www.herber.de/bbs/user/791.xls


      


    Betrifft: AW: #NV umgehen? von: Bertram
    Geschrieben am: 29.08.2003 23:39:40

    Hallo Sven,

    danke für das Upload, leider hab ich keine Ahnung, wie ich das ganz normal in mein Excel transferieren kann. Ist auch nicht sooo wichtig.

    Ich habe auch keine Ahnung, wie du deine Auswahl gestalltet hast.
    Wenn ich allerdings (bei meinem Beispiel) über 'Gültigkeit' meine Liste an Einträgen definiere, dann kann ich auch nur diese eintragen. In deinem Bespiel habe ich mal 'München' eingegeben, was zu deinem besagtem Fehler führt.

    Sei so gut und sag mir wie du deine Liste hinbekommen hast, damit sie auch listenfremde Einträge zuläßt?

    Gruß
    Bertram


      


    Betrifft: AW: #NV umgehen? von: PeterW
    Geschrieben am: 29.08.2003 23:54:04

    Hallo Bertram,

    andere Eingaben zulassen als in Liste: Daten - Gültigkeit - Registerkarte Fehlermeldung - Haken bei Fehlermeldung anzeigen raus.

    Gruß
    Peter


      


    Betrifft: AW: #NV umgehen? von: Bertram
    Geschrieben am: 30.08.2003 02:56:19

    Hallo Peter,

    danke erstmal. Wenn Sven dieses Häkchen dann nicht setzt, sollte doch sein Problem gelöst sein, da dann kein Eintrag gewählt werden kann, der nicht auf seinen SVerweis passt, oder sehe ich das falsch!?

    Gruß
    Bertram


      


    Betrifft: AW: #NV umgehen? von: PeterW
    Geschrieben am: 30.08.2003 00:04:16

    Hallo Sven,

    du musst geschachtelte Wenn-Funktionen benutzen. Wenn(Bedingung1;DannFormel1;SonstWenn(Bedingung2;DannFormel2;SonstWenn(Bedingung3;DannFormel3....

    Gruß
    Peter


      


    Betrifft: AW: #NV umgehen? von: Sven
    Geschrieben am: 30.08.2003 00:21:42

    Hallo Peter,

    verstehe, die Summenformel verschachteln. Gut, wie kann ich jetzt in der Bedingung formulieren: "wenn Zelle X1 leer, dann...?

    Wenn ich das habe, müßte es klappen.

    Gruß Sven


      


    Betrifft: AW: #NV umgehen? von: PeterW
    Geschrieben am: 30.08.2003 09:16:10

    Hallo Sven,

    =Wenn(X1="";DannFormelOderWert;SonstFormelOderWert)

    Gruß
    Peter


      


    Betrifft: AW: #NV umgehen? von: Sven
    Geschrieben am: 30.08.2003 10:03:13

    Guten Morgen Peter,

    leider hat es nicht gleich geklappt, da ich den Bezug zur Zelle mit dem sverweis hatte und diese nicht wirklich leer war (steht ja eine Formel drin). Jetzt kam ich auf die Idee, den Bezug auf die Zelle, die den sverweis sozusagen speist, zu beziehen und siehe da, es funktioniert.
    Vielen Dank für Deine Unterstützung, war ein harter Brocken.

    Schönes Wochenende
    Sven