Microsoft Excel

Herbers Excel/VBA-Archiv

Summeprodukt

    Betrifft: Summeprodukt von: Daniel
    Geschrieben am: 02.09.2003 12:14:27

    Hallo Freunde,
    noch ein Problem:
    in D53 habe die Formel:
    =SUMMENPRODUKT((B8:B52="Apfel")*(D7:D51="F")) .
    Ich möchte gleichzeitig wissen
    =SUMMENPRODUKT((B8:B52="Apfel")*(D7:D51="F1")).
    Ich habe versucht mit eine 2. Matrix....Erfolglos.
    Weiß jemand wie soll die Formel formatiert sein?

    Danke Daniel.

      


    Betrifft: AW: Summeprodukt mit ODER von: Boris
    Geschrieben am: 02.09.2003 12:26:43

    Hi Daniel,

    =SUMMENPRODUKT((B8:B52="Apfel")*(D7:D51={"F"."F1"})

    oder

    =SUMMENPRODUKT((B8:B52="Apfel")*((D7:D51="F1")+(D7:D51="F"))

    oder

    =SUMMENPRODUKT((B8:B52="Apfel")*(LINKS(D7:D51)="F")) - zählt aber auch F2 etc...

    Grüße Boris


      


    Betrifft: AW: Summeprodukt mit ODER von: Daniel
    Geschrieben am: 02.09.2003 12:50:17

    Hallo Boris,
    vielen Danke
    Alle 3 Varianten sind gut, die 3. ist die beste!!!
    Danke.
    Habe noch 'ne Frage: (ich werde auch noch ein Beitrag erfassen)
    Ich will die Formel 30 mal kopieren.
    wenn aber die Formel einfüge verchiebt Excel auch die Zellen (C8:C52... E7:E51 und so weiter).
    Mein Problem: B8:B52 muss immer gleich bleiben!(Die Äpfel stehen nähmlich da!!! :-))
    Bis jezt habe die Formel nach d. Einfügen immer manuell korregiert!!!! Sehr mühsam!!
    Gibt es eine Alternative?
    Danke
    Daniel


      


    Betrifft: AW: Summeprodukt mit ODER von: Marcus Rose
    Geschrieben am: 02.09.2003 12:53:10

    Hallo Daniel,

    so schreibe $B8:$B53 Das $-Zeichen sorgt dafür, dass sich die Formel an den relevanten Stellen nicht ändert.



    Gruß Marcus

    Die neue Excel-Homepage für Anfänger


      


    Betrifft: Danke von: Daniel
    Geschrieben am: 02.09.2003 13:39:02

    .


      


    Betrifft: AW: Summeprodukt von: Marcus Rose
    Geschrieben am: 02.09.2003 12:27:40

    Hallo,

    warum sollte das nicht klappen, wenn es bei mir geht? Vielleicht, Weil Du das Summenprodukt einmal von B8 bis B52 und dann von D7 bis D51 holst? Probiere das mal.

    Tabelle1
     BCDE
    7    
    8Apfel F 
    9Birne  2
    10Apfel F 
    11Apfel F11
    12    
    Formeln der Tabelle
    E9 : =SUMMENPRODUKT((B8:B11="Apfel")*(D8:D11="F"))
    E11 : =SUMMENPRODUKT((B8:B11="Apfel")*(D8:D11="F1"))
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
    Gruß Marcus

    Die neue Excel-Homepage für Anfänger

      


    Betrifft: Danke für dein Antwort von: Daniel
    Geschrieben am: 02.09.2003 12:52:02

    Danke Markus