Microsoft Excel

Herbers Excel/VBA-Archiv

Häufigkeit von Namen in Liste zählen

    Betrifft: Häufigkeit von Namen in Liste zählen von: Dirk K.
    Geschrieben am: 03.09.2003 09:44:44

    Hallo,

    ich habe folgendes Problem: In Spalte A habe ich eine Liste mit unterschiedlichen Namen. Manche Namen können mehrmals vorkommen. Nun möchte ich in Spalte B alle vorkommenden Namen angezeigt bekommen und in Spalte C die Häufigkeit.
    Wer kennt eine Lösung??

      


    Betrifft: AW: Häufigkeit von: Marcus Rose
    Geschrieben am: 03.09.2003 09:51:59

    Hallo

    Bei der Häufigkeit kann ich einen Tip geben

    {=SUMME(1/ZÄHLENWENN(A1:A10;A1:A10))}

    Mit Strg-Shift-Enter bestätigen, da Array


    Gruß Marcus

    Die neue Excel-Homepage für Anfänger


      


    Betrifft: AW: Häufigkeit von: Dirk K.
    Geschrieben am: 03.09.2003 11:23:35

    Hallo Marcus,

    danke ersteinmal für die schnelle Antwort.
    Die Lösung hilft mir so nicht weiter. Die Anzahl der unterschiedlichen Namen ist uninteressant. Was ich benötige ist: Welche Namen kommen vor und wie oft.

    Beispiel:
    Spalte A Spalte B Spalte C
    Meier Meier 2
    Müller Müller 1
    Schulze Schulze 2
    Meier
    Schulze


      


    Betrifft: AW: Häufigkeit von Namen in Liste zählen von: Mac4
    Geschrieben am: 03.09.2003 11:47:55

    Hallo Dirk,

    wie wärs mit dem Spezialfilter und hier dann ohne Duplikate in Spalte B kopieren. Spalte C dann über Zählenwenn.

    Marc


      


    Betrifft: AW: Häufigkeit von Namen in Liste zählen von: Dirk K.
    Geschrieben am: 03.09.2003 12:02:44

    Hallo Marc,

    danke für den Hinweis. Hilft mir weiter.

    Dirk