Wochenplan mit Kriterium

Bild

Betrifft: Wochenplan mit Kriterium
von: Golem
Geschrieben am: 24.09.2003 10:26:38


Hallo, habe folgendes Problem :

Es gibt pro Tag 2 Schichten (früh&spät). Pro SChicht dürfen nur maximal 2000 Stück "bearbeitet" werden (->Summe max.2000).Wie kann man per Makro es so hinbekommen, dass bei Erreichen der 2000 Stück die nächsten (2000)Stück in die Spätschicht geschrieben werden?(siehe Tabelle)

https://www.herber.de/bbs/user/1147.xls

Stück und Sachnr. sind jeweils Felder (Arrays). Die Bsp.Tabelle hat nur einen Tag, es soll aber für mehrere Tage spaltenweise erstellt werden.

Vielen lieben Dank gebührt dem der dieses Rätsel lösen kann!

Gruß Golem

Bild


Betrifft: AW: Wochenplan mit Kriterium
von: Holger Levetzow
Geschrieben am: 24.09.2003 10:51:35

für den ganz konkreten fall sieh mal unter https://www.herber.de/bbs/user/1148.xls
nach. Ich habe folgenden Code eingefügt, der den Wert aus der 1. Tabelle in die 2. tabelle (1. freie Zeile) einträgt, sobald die Summe über 2000 geht.

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 3 And Target.Row >= 3 And Target.Row <= 8 Then
    If Range("C9") > 2000 Then
    Range(Target.Address, Target.Offset(0, -1)).Select
    Selection.Copy
    Range("E9").End(xlUp).Offset(1, 0).Select
    Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
        :=False, Transpose:=False
    Range(Target.Address, Target.Offset(0, -1)).ClearContents
    Range("E9").End(xlUp).Offset(1, 0).Select
    End If
End If
End Sub

Holger


Bild


Betrifft: AW: Wochenplan mit Kriterium
von: golem
Geschrieben am: 24.09.2003 10:56:07

Uff, recht vielen Dank für die Arbeit die Du dir gemacht hast.
Muß schon sagen das ist das schnellst-anwortenste Forum das ich kenne, weiter so!
Gruß Goli


Bild


Betrifft: dynamisch
von: Golem
Geschrieben am: 24.09.2003 11:10:03

Hallo Holger,
Prima, der Code funkt soweit! kleines Prob gibts noch:
Wie kann man die Zeilen dynamisch erweitern, so daß man mehr als 6 Sachnr. schreiben kann, geht das mit Macrorec oder besser mit dieser Redim anweisung (mit der ich mich nicht gut auskenne)?

Vielen Dank Golem


Bild


Betrifft: AW: dynamisch
von: Holger Levetzow
Geschrieben am: 24.09.2003 11:25:12

es wird doch einen festen Bereich geben, in dem die Daten eingetragen werden (die Summe wird ja in einer eindeutigen Zelle berechnet). Passe nur die Zeilennummern an in Target.Row >= 3 And Target.Row <= 8, und das müsste reichen.

Holger


Bild


Betrifft: AW: dynamisch
von: Golem
Geschrieben am: 24.09.2003 11:58:52

die Daten werden von einem anderen Sheet eingelesen und in die Wochenplantabelle reingeschrieben, kann die Summe dann per Zähler eine Zeile runtergerückt werden?

Gruß Golem


Bild


Betrifft: AW: dynamisch
von: Holger Levetzow
Geschrieben am: 24.09.2003 12:25:31

das ist mir nicht ganz klar. Wenn du z.B. in C3 bis C8 die Zahlen eingibst, steht die Summe in C9. Kommt ein neuer Wert, wie willst Du das bewerkstelligen. Per Makro kann man die Summe natürlich runterschieben, aber dazu muss ich z.B. erst den Wert in C9 eingeben.
Am besten, Du durchdenkst den Aufbau Deiner Tabelle. Vielleicht sollte die Summe auch ganz woanders stehen, z.B. in Zeile 1 oder 2. Dann wäre es leicht, zu testen, ob der Wert in Spalte 3 ab Zeile 3 eingetragen wird.

Holger


Bild


Betrifft: AW: dynamisch
von: golem
Geschrieben am: 24.09.2003 12:32:38

Vermutlich hast Du recht, der Tabellenaufbau ist nicht sehr verständlich - eine Generalüberholung wäre nötig.
Wahrscheinlich wäre es, wie es Excel sp schön nennt, ein Zirkelverweis/bezug.

mfg Golem


Bild


Betrifft: AW: Wochenplan mit Kriterium
von: Gert Seler
Geschrieben am: 24.09.2003 11:11:06

Hallo Golem,
in A1 2000; A2=Zahl_Übertrag (aus Vorwoche oder Vortag).
In B6 und E6 "Übertrag". In C6 die Formel =WENN(A2>$A$1;A2-$A$1;"")
und F6 die Formel =WENN(C9>$A$1;C9-$A$1;"").
Wichtig sind die Überträge aus den Summen (Zeile 9)größer A1.
Die Zelle A1 ist absolut gesetzt. Hier können auch andere Sollzahlen eingetragen werden.
Ich hoffe Dir ist damit geholfen.
mfg
Gert


Bild


Betrifft: Danke Gert
von: Golem
Geschrieben am: 24.09.2003 11:20:41

Hi, bin zwar mehr auf der Suche nach der VBA Lösung aber ich versuche mal Deine Lsg mit Macrorec

Gruß Golem


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Wochenplan mit Kriterium"