Matrixformeln bei gefilterter Datei

Bild

Betrifft: Matrixformeln bei gefilterter Datei
von: Andre Giere
Geschrieben am: 30.09.2003 13:07:16

Ich habe eine Datei, die zuverlässig Summenprodukte über eine Matrixformel
ermittelt.

Ist dies irgendwie auch bei gefilterter Anzeige (dann nur für die sichtbaren
Werte)möglich?

D.h. kann man die Funktion "Teilergebnis" irgendwie mit der Matrixformel
kombinieren?

Für jede Hilfe dankbar,
Andre

Bild


Betrifft: Matrixformeln bei gefilterter Datei
von: Boris
Geschrieben am: 30.09.2003 13:13:26

Hi Andre,

ja, kann man:
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(1:1000)))*(B1:B1000="x")*C1:C1000)

ermittelt z.B. aus dem gefilterten Bereich A1:C1000 die SUMME aus den sichtbaren Zellen in C1:C1000, wenn in den sichtbaren Zellen B1:B1000 ein "x" steht.

Grüße Boris


Bild


Betrifft: AW: Matrixformeln bei gefilterter Datei
von: Andre Giere
Geschrieben am: 30.09.2003 14:10:22

Hallo Boris,

Vielen Dank für die superschnelle Antwort. Ich mußte es etwas
anpassen (ich habe das ="X" rausgenommen), aber jetzt funktioniert
es prächtig. Ich bin echt baff.

Vielen, vielen Dank nochmal.

Andre


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Matrixformeln bei gefilterter Datei"