Microsoft Excel

Herbers Excel/VBA-Archiv

Werte aus Liste

    Betrifft: Werte aus Liste von: Lokutus
    Geschrieben am: 05.10.2003 13:01:59

    Hallo,

    ich habe eine unsortierte 6 Spalten große Liste (Zeilen unendlich viele) und möchte in Spalte B in der Namen stehen (kommen mehrfach vor)diese Namen in einem anderen Tabellenblatt zu einer weiteren Auswahl haben. In der Spalte stehen also zB. Schmidt, Müller, Meier, Meier, Schmidt. Die Ergebnisliste soll also nur Schmidt, Meier und Müller enthalen.

    Wie würde die Formel aussehen müssen.

    Vielen Dank

    Lokutus

      


    Betrifft: Werte aus Liste ohne Doppler von: Boris
    Geschrieben am: 05.10.2003 13:17:57

    Hi Lokutus,

    bei "endlos" vielen Zeilen muss auf jeden Fall eine Lösung mit Hilfsspalte her, da eine Array-Formel zu lange berechnet.

    Das könnte dann so aussehen:
    In Spalte B deine Namensliste mit doppelten, Spalte C = Hilsspalte, Spalte E alle Namen nur 1 mal (ohne Formeln geht es im übrigen mit dem Spezialfilter, Häkchen bei "Keine Duplikate"):

     ABCDE
    1 NamenHilfsspalte Alle nur einmal:
    2 Schmidt2 Fischer
    3 Müller3 Schuster
    4 Meier4 Lehmann
    5 Meier0 Meier
    6 Schmidt0 Müller
    7 Müller0 Schmidt
    8 Lehmann8  
    9 Schuster9  
    10 Schuster0  
    11 Lehmann0  
    12 Schmidt0  
    13 Fischer13  
    Formeln der Tabelle
    C2 : =(ZÄHLENWENN($B$2:B2;B2)=1)*ZEILE()
    E2 : =WENN(ZEILEN($1:1)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:1));C:C;0)))
    C3 : =(ZÄHLENWENN($B$2:B3;B3)=1)*ZEILE()
    E3 : =WENN(ZEILEN($1:2)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:2));C:C;0)))
    C4 : =(ZÄHLENWENN($B$2:B4;B4)=1)*ZEILE()
    E4 : =WENN(ZEILEN($1:3)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:3));C:C;0)))
    C5 : =(ZÄHLENWENN($B$2:B5;B5)=1)*ZEILE()
    E5 : =WENN(ZEILEN($1:4)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:4));C:C;0)))
    C6 : =(ZÄHLENWENN($B$2:B6;B6)=1)*ZEILE()
    E6 : =WENN(ZEILEN($1:5)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:5));C:C;0)))
    C7 : =(ZÄHLENWENN($B$2:B7;B7)=1)*ZEILE()
    E7 : =WENN(ZEILEN($1:6)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:6));C:C;0)))
    C8 : =(ZÄHLENWENN($B$2:B8;B8)=1)*ZEILE()
    E8 : =WENN(ZEILEN($1:7)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:7));C:C;0)))
    C9 : =(ZÄHLENWENN($B$2:B9;B9)=1)*ZEILE()
    E9 : =WENN(ZEILEN($1:8)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:8));C:C;0)))
    C10 : =(ZÄHLENWENN($B$2:B10;B10)=1)*ZEILE()
    E10 : =WENN(ZEILEN($1:9)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:9));C:C;0)))
    C11 : =(ZÄHLENWENN($B$2:B11;B11)=1)*ZEILE()
    E11 : =WENN(ZEILEN($1:10)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:10));C:C;0)))
    C12 : =(ZÄHLENWENN($B$2:B12;B12)=1)*ZEILE()
    E12 : =WENN(ZEILEN($1:11)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:11));C:C;0)))
    C13 : =(ZÄHLENWENN($B$2:B13;B13)=1)*ZEILE()
    E13 : =WENN(ZEILEN($1:12)>ZÄHLENWENN(C:C;">0");"";INDEX(B:B;VERGLEICH(KGRÖSSTE(C:C;ZEILEN($1:12));C:C;0)))
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Grüße Boris

      


    Betrifft: Es reicht übrigens, die Formeln in C2 und E2... von: Boris
    Geschrieben am: 05.10.2003 13:19:26

    ...einzutragen. Diese kan man dann einfach runterkopieren.

    Boris


      


    Betrifft: AW: Es reicht übrigens, die Formeln in C2 und E2... von: Lokutus
    Geschrieben am: 05.10.2003 18:33:29

    Danke Boris du hast mir sehr geholfen.

    MfG Lokutus


      


    Betrifft: AW: Werte aus Liste ohne Doppler von: Hasan
    Geschrieben am: 05.10.2003 16:23:18

    Hallo Boris
    Bin Anfänger und habe eine Frage an dich
    wie kann ich deine Formel ändern wenn die Liste ist in diese Bereicht
    B100:B1000
    Habe versucht aber bekommen nicht hin :-(
    Danke Hasan