Microsoft Excel

Herbers Excel/VBA-Archiv

Erweiterter SUMMEWENN-Befehl ????

    Betrifft: Erweiterter SUMMEWENN-Befehl ???? von: Jan S.
    Geschrieben am: 06.10.2003 14:30:06

    Hallo,
    ich habe eine Frage zu einem Excel-Problem.
    Summewenn addiert ja die Zelle, wenn eine dazugehörige Zelle mit einem Merkmal übereinstimmt. Nun bräuchte ich einen Befehl, der genauso Zellen addiert, aber als Voraussetzung nicht nur die Übereinstimmung prüft, sondern erst eine komplexere Gleichung prüft. Z.B.: Summiere die Werte der Spalte B, wenn der dazugehörige Wert in Spalte A, größer als 3 und kleiner als 27 ist.

    Geht sowas mit Summewenn ? Wenn ja, wie ?
    Wenn nein: Wie könnte ich das Problem lösen ??

    Vielen Dank im voraus !!!

    Gruss Jan

      


    Betrifft: AW: Erweiterter SUMMEWENN-Befehl ???? von: Lars
    Geschrieben am: 06.10.2003 14:36:38

    =WENN(27>A1>3;(SUMME(B1:B7)))

    denke mit der Formel sollte Dein Prob keines mehr sein! :-)

    Gruß Lars


      


    Betrifft: AW: Erweiterter SUMMEWENN-Befehl ???? von: Lars
    Geschrieben am: 06.10.2003 14:57:10

    =WENN(UND(A1>3;A1<27);(SUMME(B1:B7)))

    ups, ist mir wohl ein kleiner Fehler unterlaufen!! Hiermit funzt es jetzt aber wirklich!!! Sorry!

    Gruß Lars


      


    Betrifft: AW: Erweiterter SUMMEWENN-Befehl ???? von: Jan S.
    Geschrieben am: 06.10.2003 15:08:51

    Hallo Lars,
    erstmal Danke für deine schnelle Antwort.
    Deine Formal löst leider noch nicht mein Problem. Wahrscheinlich habe ich mich etwas zu undeutlich ausgedrückt. Sorry ! Mit deiner Formel werden verschiedene Zellen addiert, wenn die Bedingung in einer (!) Zelle erfüllt sind. In meinem Fall soll ähnlich wie bei summewenn, z.B: B5 nur dann zur Summe hinzugezogen werden, wenn A5 die Voraussetzung (27>A5>3) erfüllt. Genauso soll nur dann B3 hinzuaddiert werden, wenn A3 die Voraussetzung erfüllt.

    Anwendungsbeispiel:
    In Spalte A steht das Startdatum eines Geschäftes
    In Spalte B steht das Enddatum eines Geschäftes
    In Spalte c steht das Geschäftvolumen.

    Manche Geschäfte sind abgelaufen, andere laufen gerade oder starten erst in der Zukunft.
    Wenn man jetzt per Formal abfragen will, was für ein Volumen von Geschäft zum Datum Y bestanden haben sollte die Formel Folgendes machen:

    Summiere die Zellen in Spalte C, deren Spalte B-Wert in der gleiche Zeile größer als y ist und deren Spalte a-Wert in der gleiche Zeile kleiner als y ist.



    Versteht ihr mein Problem ??
    Kennt ihr eine Lösung ???


      


    Betrifft: =summenprodukt von: Günther Oppold
    Geschrieben am: 06.10.2003 15:16:38

    Hi Jan,

    mit Summenprodukt kannst Du mehrere Bedingungen abfragen
    =Summenprodukt((A1:A999<="y")*(B1:B999>="y")*C1:C999)

    Günther


      


    Betrifft: DANKE !!! von: Jan S.
    Geschrieben am: 06.10.2003 15:25:42

    Hallo Günther,
    es klappt !!
    Vielen Dank !!
    Du bist echt ein Excel-Gott !!!