Samstag /Sonntag als freier Tag

Bild

Betrifft: Samstag /Sonntag als freier Tag
von: Anja Kronfeld
Geschrieben am: 06.10.2003 17:40:03

Möchte in meine Arbeitszeiterfassung folgende Formel einbauen
=wenn Wochentag in B8 = Samstag dann mit 0 rechnen ansonsten mit 8 rechnen.Kann mir jemand die richtige Formel dazu sagen?
Im voraus vielen Dank

Bild


Betrifft: AW: Samstag /Sonntag als freier Tag
von: Hajo_Zi
Geschrieben am: 06.10.2003 17:55:21

Hallo Anja

ein Hallo zu Beginn und ein Gruß am Ende läst den Beitrag doch gleich viel freundlicher aussehen. Auch wenn Du den Beitrag am Computer eingibst sitzen an der anderen Seite doch Leute und keine Maschinen die Deine Frage beantworten und da sollte Zeit für die paar Worte doch vorhanden sein.

Tabelle3
 ABCDEF
1vom:01.11.2003    
2bis:30.11.2003    
3      
4Arbeitszeit:08:00 [Std]   
5Übertrag
Vormonat :
8,00[z.B. 36,68 Std]   
6Pause:00:45[Std]   
7      
8Zeiterfassung     
9Tag Arbeitsort
Bemerkung
Beginn
[Zeit]
Ende
[Zeit]
Pause
[Zeit]
1001.11.03Samstag    
1102.11.03Sonntag    
1203.11.03Montag    
Formeln der Tabelle
B2 : =MONATSENDE(B1;0)
A10 : =B1
B10 : =A10
E10 : =WENN(D10=0;;WENN(WOCHENTAG(A10;2)<>6;D10+FixZeit+Pause;""))
F10 : =WENN(A10=0;0;WENN(D10=0;0;Pause))
A11 : =WENN(A10>=$B$2;"";WENN(A10=0;;A10+1))
B11 : =A11
E11 : =WENN(D11=0;;WENN(WOCHENTAG(A11;2)<>6;D11+FixZeit+Pause;""))
F11 : =WENN(A11=0;0;WENN(D11=0;0;Pause))
A12 : =WENN(A11>=$B$2;"";WENN(A11=0;;A11+1))
B12 : =A12
E12 : =WENN(D12=0;;WENN(WOCHENTAG(A12;2)<>6;D12+FixZeit+Pause;""))
F12 : =WENN(A12=0;0;WENN(D12=0;0;Pause))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/

Bild


Betrifft: AW: Samstag /Sonntag als freier Tag
von: andreas e
Geschrieben am: 06.10.2003 17:56:55

Hallo,
hier ein kleines Bsp.:
 
 ABC
1Datumwert nur SamstagWert sa und so
201.09.200311
302.09.200311
403.09.200311
504.09.200311
605.09.200311
706.09.200300
807.09.200310
908.09.200311
1009.09.200311
1110.09.200311
1211.09.200311
1312.09.200311
1413.09.200300
Formeln der Tabelle
B2 : =WENN(WOCHENTAG(A2)=7;0;1)
C2 : =WENN(ODER(WOCHENTAG(A2)=1;WOCHENTAG(A2)=7);0;1)
B3 : =WENN(WOCHENTAG(A3)=7;0;1)
C3 : =WENN(ODER(WOCHENTAG(A3)=1;WOCHENTAG(A3)=7);0;1)
B4 : =WENN(WOCHENTAG(A4)=7;0;1)
C4 : =WENN(ODER(WOCHENTAG(A4)=1;WOCHENTAG(A4)=7);0;1)
B5 : =WENN(WOCHENTAG(A5)=7;0;1)
C5 : =WENN(ODER(WOCHENTAG(A5)=1;WOCHENTAG(A5)=7);0;1)
B6 : =WENN(WOCHENTAG(A6)=7;0;1)
C6 : =WENN(ODER(WOCHENTAG(A6)=1;WOCHENTAG(A6)=7);0;1)
B7 : =WENN(WOCHENTAG(A7)=7;0;1)
C7 : =WENN(ODER(WOCHENTAG(A7)=1;WOCHENTAG(A7)=7);0;1)
B8 : =WENN(WOCHENTAG(A8)=7;0;1)
C8 : =WENN(ODER(WOCHENTAG(A8)=1;WOCHENTAG(A8)=7);0;1)
B9 : =WENN(WOCHENTAG(A9)=7;0;1)
C9 : =WENN(ODER(WOCHENTAG(A9)=1;WOCHENTAG(A9)=7);0;1)
B10 : =WENN(WOCHENTAG(A10)=7;0;1)
C10 : =WENN(ODER(WOCHENTAG(A10)=1;WOCHENTAG(A10)=7);0;1)
B11 : =WENN(WOCHENTAG(A11)=7;0;1)
C11 : =WENN(ODER(WOCHENTAG(A11)=1;WOCHENTAG(A11)=7);0;1)
B12 : =WENN(WOCHENTAG(A12)=7;0;1)
C12 : =WENN(ODER(WOCHENTAG(A12)=1;WOCHENTAG(A12)=7);0;1)
B13 : =WENN(WOCHENTAG(A13)=7;0;1)
C13 : =WENN(ODER(WOCHENTAG(A13)=1;WOCHENTAG(A13)=7);0;1)
B14 : =WENN(WOCHENTAG(A14)=7;0;1)
C14 : =WENN(ODER(WOCHENTAG(A14)=1;WOCHENTAG(A14)=7);0;1)
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Gruß Andreas E http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr http://www.fachforen.de eine Linksammlung zu diversen fachforen

 Bild

Beiträge aus den Excel-Beispielen zum Thema " Samstag /Sonntag als freier Tag"