Matrix + Mittelwertberechnung nach Datum

Bild

Betrifft: Matrix + Mittelwertberechnung nach Datum
von: Korl
Geschrieben am: 07.10.2003 09:08:53

Hallo,

ich habe ein Tabellenblatt in der Holzstämme nach Festmetern und Stückzahl summiert und Mittelwerte von Längen, Durchmesser und Festmeter pro Datum eingetragen werden.

Im nächsten Tabellenblatt möchte ich eine monatliche Zusammenfassung derselben erreichen.

Dazu habe ich für die Summenspalten diese Matrixformel:
{=SUMME(WENN(MONAT(Tabelle1!$B$9:$B$3000)=MONAT($B3);(Tabelle1!D$9:D$3000);""))}

Für meine Mittelwerte diese Matrixformel:
{=MITTELWERT(WENN(MONAT(Tabelle1!$B$9:$B$3000)=MONAT($B3);(Tabelle1!F$9:F$3000);""))}

Diese Formeln erledigen auch das was sie sollen in den einzelnen Monaten,
außer im Monat "Januar" wird die Mittelwertberechnung nicht bzw. falsch durchgeführt.

Kann da jemand helfen? Danke schon mal im Voraus.

Gruß Korl

Bild


Betrifft: AW: Matrix + Mittelwertberechnung nach Datum
von: Mac4
Geschrieben am: 07.10.2003 09:37:44

Mon Korl,

ohne Deine Datei gesehen zu haben, nehme ich an, dass in dem Bereich noch Leerzellen existieren. Diese Leerzellen werden als 1 interpretiert und somit als Monat Januar betrachtet. Du musst Deine Abfrage noch erweitern und Leerzellen ausschließen!

Marc


Bild


Betrifft: MONAT(Leerzelle) = 1 - Warum? Darum...
von: Boris
Geschrieben am: 07.10.2003 09:50:03

Hi Marc,

inzwischen ist mit im übrigen auch klar, warum das so ist:
A1 ist leer - =MONAT(A1) liefert 1 - warum?
Ganz einfach:
Die Datumsberechnung in Excel beginnt mit dem 00.01.1900 - und in diesem Fall ist LEER = NULL (das wandelt die Funktion MONAT automatisch so um).
Also heisst es übersetzt:
=MONAT(00.01.1900) - und das ist nunmal der Januar.

Das nur zur Info - vielleicht war es dir ja aber auch schon bekannt.

Grüße Boris


Bild


Betrifft: AW: MONAT(Leerzelle) = 1 - Warum? Darum...
von: Mac4
Geschrieben am: 07.10.2003 09:52:21

Hi Boris,

danke für die Hintergrundinfo. Ich hatte das bisher einfach so hingenommen - zu wissen warum ist aber das deutlich bessere Gefühl!

Marc


Bild


Betrifft: AW: Matrix + Mittelwertberechnung nach Datum
von: Korl
Geschrieben am: 07.10.2003 10:18:25

Hi Marc und Boris,

Danke für Deine Antwort-wie müßte die Formel dann aussehen?
So gut bin ich dann doch wie nicht!

Gruß Korl


Bild


Betrifft: AW: Matrix + Mittelwertberechnung nach Datum
von: Mac4:
Geschrieben am: 07.10.2003 10:30:42

Hi,
war falsch angehängt!
So müsste es gehen:

{=SUMME(WENN(MONAT(Tabelle1!$B$9:$B$3000)=MONAT($B3);Wenn(Tabelle1!$B$9:$B$3000<>"";(Tabelle1!D$9:D$3000);"")))}
{=MITTELWERT(WENN(MONAT(Tabelle1!$B$9:$B$3000)=MONAT($B3);Wenn(Tabelle1!$B$9:$B$3000<>"";(Tabelle1!F$9:F$3000);"")))}

Marc




Bild


Betrifft: AW: Matrix + Mittelwertberechnung nach Datum
von: Mac4
Geschrieben am: 07.10.2003 10:29:28

Hi,

so müsste es gehen:

{=SUMME(WENN(MONAT(Tabelle1!$B$9:$B$3000)=MONAT($B3);Wenn(Tabelle1!$B$9:$B$3000<>"";(Tabelle1!D$9:D$3000);"")))}
{=MITTELWERT(WENN(MONAT(Tabelle1!$B$9:$B$3000)=MONAT($B3);Wenn(Tabelle1!$B$9:$B$3000<>"";(Tabelle1!F$9:F$3000);"")))}

Marc


Bild


Betrifft: AW: Matrix + Mittelwertberechnung nach Datum
von: Korl
Geschrieben am: 07.10.2003 10:47:24

Hi Marc,

besten Dank für Deine Hilfe, es klappt super.
Und wieder was dazu gelernt. ;-)

Gruß Korl


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Matrix + Mittelwertberechnung nach Datum"