kopiere zellen deren inhalte funktionen sind

Bild

Betrifft: kopiere zellen deren inhalte funktionen sind
von: ChrisNa
Geschrieben am: 10.10.2003 19:32:39

Hi xl-Forum

ich kopiere den Inhalt eins Zellbereiches welcher eine Funktion enthält mit dem Codeschnipsel

Workbooks(A_DN).Sheets(A_AB1).Activate
ActiveSheet.Range("A" & CountUCN).Copy _
Destination:=Workbooks(A_DN).Sheets _
(A_AB5).Cells(CountSchreiben, 1)

CountUCN = 4
CountSchreiben = 3
Workbooks(A_DN).Sheets(A_AB1).Activate
ActiveSheet.Range("A" & CountUCN) enhält die Funktion =wenn(B4>0;zeile(A1);"")


Das Problem ist das nun das Workbooks(A_DN).Sheets _
(A_AB5).Cells(CountSchreiben, 1) nicht die gewünschte Funktion enthält sondern
stattdessen =WENN(B3>0;ZEILE(#BEZUG!);"").

Was mach ich da falsch?

Wie kann ich statt der Funktion, nur den Wert, sprich oder besser schreib den eingetragenen wert kopieren? Geht dies überhaupt?
gruß ChrisNa

Bild


Betrifft: AW: kopiere zellen deren inhalte funktionen sind
von: Hajo_Zi
Geschrieben am: 10.10.2003 19:35:20

Hallo Chris


Sub Werte_Format()
'   Formeln ersetzen durch Werte mit Formate
    Workbooks("Datei1.xls").Worksheets("Tabelle1").Range(Sheets("Tabelle1").UsedRange.Address).Copy
    With Workbooks("Datei2.xls").Worksheets("Tabelle1").Range("A1")
        .PasteSpecial Paste:=xlValues           ' Werte
        .PasteSpecial Paste:=xlFormats      ' Formate
    End With
    Application.CutCopyMode = False
End Sub



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



Bild


Betrifft: AW: kopiere zellen deren inhalte funktionen sind
von: ChrisNa
Geschrieben am: 10.10.2003 19:51:32

Wow super Danke Hajo!
Gruß ChrisNa


 Bild

Beiträge aus den Excel-Beispielen zum Thema " kopiere zellen deren inhalte funktionen sind"