Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
320to324
320to324
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

kopiere zellen deren inhalte funktionen sind

kopiere zellen deren inhalte funktionen sind
10.10.2003 19:32:39
ChrisNa
Hi xl-Forum

ich kopiere den Inhalt eins Zellbereiches welcher eine Funktion enthält mit dem Codeschnipsel

Workbooks(A_DN).Sheets(A_AB1).Activate
ActiveSheet.Range("A" & CountUCN).Copy _
Destination:=Workbooks(A_DN).Sheets _
(A_AB5).Cells(CountSchreiben, 1)

CountUCN = 4
CountSchreiben = 3
Workbooks(A_DN).Sheets(A_AB1).Activate
ActiveSheet.Range("A" & CountUCN) enhält die Funktion =wenn(B4>0;zeile(A1);"")

Das Problem ist das nun das Workbooks(A_DN).Sheets _
(A_AB5).Cells(CountSchreiben, 1) nicht die gewünschte Funktion enthält sondern
stattdessen =WENN(B3>0;ZEILE(#BEZUG!);"").

Was mach ich da falsch?

Wie kann ich statt der Funktion, nur den Wert, sprich oder besser schreib den eingetragenen wert kopieren? Geht dies überhaupt?
gruß ChrisNa

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: kopiere zellen deren inhalte funktionen sind
10.10.2003 19:35:20
Hajo_Zi
Hallo Chris


Sub Werte_Format()
'   Formeln ersetzen durch Werte mit Formate
Workbooks("Datei1.xls").Worksheets("Tabelle1").Range(Sheets("Tabelle1").UsedRange.Address).Copy
With Workbooks("Datei2.xls").Worksheets("Tabelle1").Range("A1")
.PasteSpecial Paste:=xlValues           ' Werte
.PasteSpecial Paste:=xlFormats      ' Formate
End With
Application.CutCopyMode = False
End Sub


Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/

Anzeige
AW: kopiere zellen deren inhalte funktionen sind
10.10.2003 19:51:32
ChrisNa
Wow super Danke Hajo!
Gruß ChrisNa

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige