Feiertage grau Makieren in Zeiterfassung

Bild

Betrifft: Feiertage grau Makieren in Zeiterfassung
von: Sebastian .H
Geschrieben am: 27.10.2003 10:41:58

Hallo Leute,

Ich brauch mal wieder Hilfe von euch! Also ich habe mir gedacht ich vereinfache mir das ewige neu markieren von Feiertage in meiner Excel-Tabelle und was ich bereits gemacht habe, die Änderung des Datums. Ich habe mir gedacht ich setze eine Formel ein die mir in jedes Feld das Datum einträgt (das Ergebnis darf natürlich auf dem Ausdruck nicht zu sehen sein...) und lass danach ein Makro drüber laufen welches sich die Feiertag aus einer Liste holt die in einem anderem Blatt liegt.

Das vorerst zur Erklärung was ich vorhabe!!!

Problem Nr 1:
Ich finde keinen Menüpunkt der es mir erlaubt gewisse zahlen gar nicht erst zu drucken, bzw. sogar die Formel nur im Hintergrund läuft und die werte gar nicht erscheinen... Ist das irgendwie möglich?

Problem Nr 2:
Wie könnte das Makro aussehen womit ich die Zellen markieren die ein Feiertag sein sollen?

Ich würde mich über Hilfe von euch sehr Freuen

danke schon einmal im voraus
Sebastian.H

Bild


Betrifft: AW: Feiertage grau Makieren in Zeiterfassung
von: Ralf
Geschrieben am: 27.10.2003 11:06:39

Hallo Sebastian,
zu 1.
Nehme als Textfarbe die Hintergrundfarbe der Zelle und auf Deinem Ausdruck ist die Formel unsichtbar.
zu 2.
Füge in die Zelle mit dem Datum eine "bedingte Formatierung" ein.
z.B. Wenn Zellwert = Datum (XYZ) Dann Zellfarbe Grau.

Gruß Ralf


Bild


Betrifft: AW: Feiertage grau markieren
von: Galenzo
Geschrieben am: 27.10.2003 11:12:54

Hallo, zu deinem Problem #2 schau dir mal diesen Beitrag an:

Betrifft: AW: Muster der Zellenformatierung
von: Galenzo
Geschrieben am: 21.10.2003 12:48:32

Hallo,

für dieses Problem empfehle ich dir die "Bedingte Formatierung".
Vorraussetzung: in der Tabelle stehen irgendwo die Feiertage (diese Spalte kann auch ausgeblendet sein) Als Beispiel nehme ich hier mal an, daß im Bereich Y1:Y20 untereinander die Feiertage stehen - jeweils das Datum.
Als Formel für die bedingte Formatierung kannst du nun eintragen (hier z.B. für die Zelle A1):
"Formel ist:" "=VERGLEICH(A1;$Y$1:$Y$20;0)" - und leg noch ein Format fest.

Für die Erstellung einer Datumsreihe:
Trage beispielsweise in A1 ein: 01.01.2003
Dann die Formel in A2: =A1+1
Und diese dann auf die ganze Spalte runterziehen.
So brauchst du nur noch Zelle A1 zu ändern - und die ganze Spalte ändert sich mit.

Dann viel Erfolg!


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Feiertage grau Makieren in Zeiterfassung"