Zuordung

Bild

Betrifft: Zuordung
von: b0041920
Geschrieben am: 03.11.2003 22:19:53

Hallo,
Vielleicht kann mir jemand weiterhelfen:
Ich möchte per Makro die im unteren Teil meiner Liste dargestellten Kontonummern (hier im Bsp. ab Zl. 12) in der rechts danebenliegenden Spalte (Spalte C) mit den Werten versehen. Die Werte lassen sich aus den oben dargestellten Konten (Zl 1-7) zusammensetzen. Fest verknüpfen kann ich die Postionen nicht, da sich der obige Teil der Liste im Umfang von Fall zu Fall ändern kann.
Ich habe aber eine eindeutige Zuordungstabelle.

_______SpalteA__SpalteB__Spalte C
________Betrag_Kontonr___Betrag
Zeile1___1,00___110
Zeile2___2,00___111
Zeile3___5,00___112
Zeile4___8,00___113
Zeile5__10,00___114
Zeile6__12,00___115
Zeile7___7,00___116
Zeile8_________.
Zeile9_________.
Zeile10________.
Zeile11________.________________Bermerkung: Betrag
Zeile12_________576_______3,00___=Kto 110 + Kto 111
Zeile13_________577_______5,00___=Kto 112
Zeile14_________578______27,00___=Kto 113 + Kto 115 + Kto 116
_______________.
_______________.
Vielen Dank im Voraus.

Bild


Betrifft: AW: Zuordung - Matrixformeln
von: Galenzo
Geschrieben am: 04.11.2003 10:18:39

Hallo,
eigentlich brauchst du dazu kein VBA - benütze "Matrixformeln"
Diese sähen dann so aus:

Zeile12: {=SUMME(WENN(B2:B8={110.111};A2:A8;0))}
Zeile13: {=SUMME(WENN(B2:B8=112;A2:A8;0))}
Zeile14: {=SUMME(WENN(B2:B8={113.115.116};A2:A8;0))}

Wie immer an dieser Stelle der Hinweis, daß die äußeren geschweiften Klammern nicht direkt eingegeben werden, sondern die Eingabe in der Bearbeitungszeile wird statt nur mit ENTER hier nun mit STRG+SHIFT+ENTER abgeschlossen wird, um eben diese geschweiften Klammern zu erzeugen, die eine Matrixformel kennzeichnen.

Viel Erfolg!


Bild


Betrifft: AW: Zuordung - Matrixformeln
von: b0041920
Geschrieben am: 04.11.2003 21:19:30

Hallo,
klappt wunderbar.
Vielen Dank für den Tipp

Grüsse


Bild

Beiträge aus den Excel-Beispielen zum Thema " Hyperlink mit Makro erstellen"