Sverweis mehrere Werte

Bild

Betrifft: Sverweis mehrere Werte
von: Holger S.
Geschrieben am: 05.11.2003 21:00:36

Hallo,

mit welcher Formel kann ich aus einer Matrix
alle übereinstimenden Werte bekommen.
Mit dieser Formel bekomme ich nur den ersten
übereinstimenden Wert zurück.

=SVERWEIS(A10;'Touren 06'!H:I;2;FALSCH)
Habe aber mehrere Übereinstimende Werte.

Danke im voraus
Holger

Bild


Betrifft: AW: Sverweis mehrere Werte
von: PeterW
Geschrieben am: 05.11.2003 21:04:00

Hallo Holger,

vielleicht so?
http://www.excelformeln.de/formeln.html?welcher=28

Gruß
Peter


Bild


Betrifft: AW: Sverweis mehrere Werte
von: Holger S.
Geschrieben am: 05.11.2003 21:29:06

Gehen diese Formeln nur mit zahlen,
ich muss Text zurück haben.
Habe eine Tour Nr.
und möchte alle Kunden der Tour haben.

Tour Nr. Kunde

224455 Müller
223311 Schmidt
224455 Kaiser
223311 Keller usw............

brauch dafür eine Formel die mir alle Kunden einer Tour in einer Zelle wieder gibt.

Danke Holger


Bild


Betrifft: noch OFFEN
von: PeterW
Geschrieben am: 05.11.2003 21:45:09

Hallo Holger,

in einer Zelle dürfte das per Formel unmöglich sein (obwohl ich immer wieder staune, was mit Formeln machbar ist!).
Poste mal eine Beispieltabelle, dann lässt sich bestimmt eine VBA-Lösung finden.

Gruß
Peter


Bild


Betrifft: AW: noch OFFEN
von: Holger S.
Geschrieben am: 05.11.2003 22:00:49

Hier ist meine Tabelle

Das Blatt Touren 06 bekomme ich aus SAP/R3

https://www.herber.de/bbs/user/1762.xls


Bild


Betrifft: AW: Sverweis mehrere Werte
von: RalfH
Geschrieben am: 05.11.2003 21:47:59

Hallo Holger,

ich würde den Spezialfilter [Daten - Filter - Spezialfilter] benutzen, und damit alle Kunden einer Tour an eine andere Stelle kopieren.

Probier das mal aus

Gruss

Ralf


Bild


Betrifft: AW: Sverweis mehrere Werte
von: Arnim
Geschrieben am: 06.11.2003 00:24:29

Hallo Holger,
schreibe in C2 diese Array-Formel:
=WENN(ZEILE(A1)>ZÄHLENWENN('Touren 06'!H:H;A$2);"";INDEX('Touren 06'!I:I;KKLEINSTE(WENN('Touren 06'!H$3:H$500=A$2;ZEILE($3:$500));ZEILE(A1))))
Eingabe mit Tastenkombination Strg/Shift/Enter
und kopiere sie soweit als möglich herunter.
Du erhältst dann jeweils zu der Touren-Nr.,die Du in A2 eingibst, die entsprechenden Namen.

Gruß Arnim


Bild


Betrifft: DANKE
von: Holger S.
Geschrieben am: 06.11.2003 07:06:14

Danke
Ihr habt mir sehr geholfen.

Holger


Bild

Beiträge aus den Excel-Beispielen zum Thema " Sverweis mehrere Werte"