Formel für Excel in VBA mit Wenn abfrage und Summe

Bild

Betrifft: Formel für Excel in VBA mit Wenn abfrage und Summe
von: chris b
Geschrieben am: 06.11.2003 09:26:35

Hallo Excel Profis stehe vor einem Problem und hoffe ihr habt eine Lösung für mich,folgendes ich habe in einem VBA Modul folgenden code
ActiveCell.Formula = "=sum(F" & y & ":F" & x & ")"
dieser schreibt mir in die benannte Zelle folgende formel:
=SUMME(F3:F4)
ich möchte aber das mir das Makro eine Formel in die Active Zelle schreibt die so aussieht->
=WENN(C3>0;SUMME(F3:F7);"")
also statt F3 und F7 übernehme ich meine Variablen x und y aber ich brauche noch die Wenn abfrage zuvor ?
Ich hoffe ihr habt eine Lösung für mich
Vielen Dank Christian !

Bild


Betrifft: vielleicht so?
von: IngoG
Geschrieben am: 06.11.2003 09:33:31

HAllo Christian,
versuchs mal mit:

ActiveCell.Formula = "=if(C3>0;sum(F" & y & ":F" & x & ");"""")"

wenn c3 auch relativ zu y ist :

ActiveCell.Formula = "=if(C"&y&">0;sum(F" & y & ":F" & x & ");"""")"

sollte so funzen
Gruß Ingo


Bild


Betrifft: AW: vielleicht so?
von: Holger Levetzow
Geschrieben am: 06.11.2003 09:40:03

oder so:

ActiveCell.FormulaLocal = "=WENN(C3>0;SUMME(F3:F7);"""")"

Holger


Bild


Betrifft: AW: Formel aus Einzelteilen zusammensetzen
von: Galenzo
Geschrieben am: 06.11.2003 09:38:17

Hallo,
dann mußt du dir diese Formel aus den einzelnen Teilen zusammenbasteln:
Teilstrings werden mit & verbunden.
Du hast feste Teile und Variablen, nämlich:
"=wenn(C"
y
">0;summe(F"
y
":F"
x
");"")"
Zusammengesetzt sieht es dann also so aus:
ActiveCell.Formula = "=wenn(C" & y & ">0; summe(F" & y & ":F" & x & ");"")"

mfg


Bild


Betrifft: AW: Formel für Excel in VBA mit Wenn abfrage und Summe
von: chris b
Geschrieben am: 06.11.2003 09:45:15

Danke euch allen, der erste versuch ging schief aber ich versuchs dann gleich noch einmal ! Danke tschüss


Bild


Betrifft: Klappt noch nicht ????
von: chris b
Geschrieben am: 06.11.2003 14:29:37

Hallo Profis,
wenn ich diese Formeln die ihr mir Dankbarer weiße geschrieben habt einfüge bekomme ich folgenden fehler ?

'ActiveCell.Formula = "=if(C" & y & ">0; summe(F" & y & ":F" & x & ");"")"
'ActiveCell.Formulalocal = "=if(C>0;sum(F" & y & ":F" & x & ");"""")"
bei beiden Formeln kommt dieser fehler.
Laufzeitfehler 2004
anwendungs oder objektdefinierter fehler.
Ich hoffe ihr habt hier auch noch hilfe für mich ! Danke nocheinmal


Bild


Betrifft: AW: Klappt noch nicht so ;-)
von: IngoG
Geschrieben am: 06.11.2003 16:19:28

hallo Chris,
Bei mir läuft der code so:

ActiveCell.Formula = "=if(C" & y & ">0,sum(F" & y & ":F" & x & "),"""")"

gruß Ingo


Bild


Betrifft: AW: Klappt noch nicht so
von: chris b
Geschrieben am: 07.11.2003 07:16:39

So klappts auch bei mir :))Danke


Bild


Betrifft: Danke für die Rückmeldung oT
von: IngoG
Geschrieben am: 07.11.2003 09:22:10

.


Bild

Beiträge aus den Excel-Beispielen zum Thema " Formel für Excel in VBA mit Wenn abfrage und Summe"