Doppelte Datensätze markieren

Bild

Betrifft: Doppelte Datensätze markieren
von: Burghard
Geschrieben am: 08.11.2003 13:38:23

Hallo,
ich habe immer noch mit einem Problem zu kämpfen. Kann mir jemand den Code so umschreiben, daß bei mehreren gleichen Datensätzen der erste doppelte Datensatz mitmarkiert wird?

Hilfe wäre super! Danke im voraus!

Gruss Burghard

Beispiel:

Tabellenspalte A enthält nach Sortierung:

1
2
2
2
3
4
4
5

Nach Codeausführung (s.u.): Markiert mit roter Schrift wird:

1
2
2 rot
2 rot
3
4
4 rot
5

Ich brauche aber diese Markierung:

1
2 rot
2 rot
2 rot
3
4 rot
4 rot
5

Kann man den Code dahingehend abändern?


Sub Doppelt_Red()
Application.ScreenUpdating = False
Rng = Selection.Rows.Count
For i = Rng To 1 Step -1
myCheck = ActiveCell
ActiveCell.Offset(1, 0).Select
For j = 1 To i
If ActiveCell = myCheck Then
Selection.Font.Bold = True
Selection.Font.ColorIndex = 3
End If
ActiveCell.Offset(1, 0).Select
Next j
ActiveCell.Offset(-i, 0).Select
Next i
Application.ScreenUpdating = True
End Sub

Bild


Betrifft: AW: Doppelte Datensätze markieren
von: Nepumuk
Geschrieben am: 08.11.2003 13:47:25

Hallo Burkhard,
so geht's:

Option Explicit
Sub Doppelt_Red()
    Dim lngZeile As Long
    Application.ScreenUpdating = False
    For lngZeile = 1 To Cells(65536, 1).End(xlUp).Row
        If Cells(lngZeile, 1) = Cells(lngZeile + 1, 1) Then
            With Range(Cells(lngZeile, 1), Cells(lngZeile + 1, 1))
                .Font.Bold = True
                .Font.ColorIndex = 3
            End With
        End If
    Next
    Application.ScreenUpdating = True
End Sub


Code eingefügt mit: Excel Code Jeanie

Gruß
Nepumuk


Bild


Betrifft: AW: Doppelte Datensätze markieren
von: Burghard
Geschrieben am: 09.11.2003 21:06:23

Hallo und vielen Dank für die Hilfe. Genau das,was ich suchte!

Klappt einwandfrei! :-)

Schönen Gruß, Burghard


Bild


Betrifft: AW: Doppelte Datensätze markieren
von: Hajo_Zi
Geschrieben am: 08.11.2003 13:48:25

Hallo Burhard

das geht noch ohne VBA

Tabelle2
 A
11
22
32
42
53
64
74
85
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =ZÄHLENWENN(A:A;A1)>1Abc
A21. / Formel ist =ZÄHLENWENN(A:A;A2)>1Abc
A31. / Formel ist =ZÄHLENWENN(A:A;A3)>1Abc
A41. / Formel ist =ZÄHLENWENN(A:A;A4)>1Abc
A51. / Formel ist =ZÄHLENWENN(A:A;A5)>1Abc
A61. / Formel ist =ZÄHLENWENN(A:A;A6)>1Abc
A71. / Formel ist =ZÄHLENWENN(A:A;A7)>1Abc
A81. / Formel ist =ZÄHLENWENN(A:A;A8)>1Abc
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Pro und Excel Version XP Pro


Bild


Betrifft: AW: Sorry - habe nicht gesehen...
von: FP
Geschrieben am: 08.11.2003 17:42:31

Hallo Hajo,

... dass Du ihm genau denselben Tipp bereits gegeben hast :-(

Man sollte eben doch immer ALLE Antworten vorher lesen ;-)

Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: Doppelte Datensätze markieren
von: Burghard
Geschrieben am: 09.11.2003 21:08:19

Hallo Hajo,

vielen Dank für die Hilfe. Das klappt ebenfalls einwandfrei! :-)

Schönen Gruß, Burghard


Bild


Betrifft: AW: Doppelte Datensätze markieren - ohne VBA...
von: FP
Geschrieben am: 08.11.2003 17:39:34

Hallo Burghard,

... geht's doch viel schneller und wird bei jeder Änderung automatisch aktualisiert!

Excel Jeanie HTML
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =ZÄHLENWENN(A:A;A1)>1Abc
A21. / Formel ist =ZÄHLENWENN(A:A;A2)>1Abc
A31. / Formel ist =ZÄHLENWENN(A:A;A3)>1Abc
A41. / Formel ist =ZÄHLENWENN(A:A;A4)>1Abc
A51. / Formel ist =ZÄHLENWENN(A:A;A5)>1Abc
A61. / Formel ist =ZÄHLENWENN(A:A;A6)>1Abc
A71. / Formel ist =ZÄHLENWENN(A:A;A7)>1Abc
A81. / Formel ist =ZÄHLENWENN(A:A;A8)>1Abc
  Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild

Beiträge aus den Excel-Beispielen zum Thema " Doppelte Datensätze markieren"