Summe bei Leerzeilen

Bild

Betrifft: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 13:34:49

Hallo, ich muß die Werte einer Spalte addieren, wenn in einer anderen Spaltedie Stückzahl angegeben ist. Ohne Stückzahl soll die Zelle nicht mit addiert werden.
Bitte um Hilfe! Danke!
Juliane

Bild


Betrifft: AW: Summe bei Leerzeilen
von: GerdW
Geschrieben am: 18.11.2003 13:36:25

Der Summe sind doch Leerzellen Wurscht, wo ist das Problem?

Gerd


Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 13:40:12

Kompliziert zu erklären. Die Zeilenanzahl kann sich verändern. Formeln habe ich in jede Zeile kopiert. Aber ich muß mir das erstnochmal durch den Koppf gehen lassen.
Juliane


Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 13:40:27

Kompliziert zu erklären. Die Zeilenanzahl kann sich verändern. Formeln habe ich in jede Zeile kopiert. Aber ich muß mir das erstnochmal durch den Koppf gehen lassen.
Juliane


Bild


Betrifft: AW: Summe bei Leerzeilen
von: GerdW
Geschrieben am: 18.11.2003 13:41:40

Lad doch ein Beispiel hoch.

Gerd


Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 13:53:44

Hallo,
unter

Bild


Betrifft: AW: Summe bei Leerzeilen
von: GerdW
Geschrieben am: 18.11.2003 13:55:34

Bist du sicher?


Gerd


Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 14:00:15

https://www.herber.de/bbs/user/2015.xls

Noch einmal. In D wird die Stückzahl eingegeben. Die Seiten, Mittelböden usw. können variieren. Manchmal sind es nur eine Seite, manchmal können es aber auch zehn Seiten werden. DIV wird nicht summiert. Deshalb benötige ich die Summe , wo überall eine Stückzahl angegeben wurde. Klar?Juliane


Bild


Betrifft: AW: Summe bei Leerzeilen
von: GerdW
Geschrieben am: 18.11.2003 14:24:08

Mach doch eine einfache Abfrage:

=WENN(D2<>"";H2/D2;"")

Gerd


Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 14:36:40

Funtioniert nicht!


Bild


Betrifft: AW: Summe bei Leerzeilen
von: GerdW
Geschrieben am: 18.11.2003 14:48:21

Was funktioniert nicht?

Wenn in D nichts steht, wird die Division nicht ausgeführt.

Gerd


Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juliane
Geschrieben am: 18.11.2003 15:35:17

Danke für die Hilfe. Aber ich hab´s. War soooooooooo einfach.


Bild


Betrifft: =SUMMEWENN(A:A;"Stückzahl";B:B)
von: Boris
Geschrieben am: 18.11.2003 13:46:29

Grüße Boris


Bild


Betrifft: Uups - das wahr wohl Quatsch...oT
von: Boris
Geschrieben am: 18.11.2003 13:47:14




Bild


Betrifft: AW: Summe bei Leerzeilen
von: Juie
Geschrieben am: 18.11.2003 14:30:45

Hallo Juliane,

die Formel lautet
=SUMMEWENN(B2:B22;">0";D2:D22)

Wobei B2:B22 die Spalte mit den Stückzahl ist und D2:D22 die Spalte welche gezählt werden soll.

Gruss Juie


Bild


Betrifft: Nachtrag
von: Juie
Geschrieben am: 18.11.2003 14:46:26

Hallo Juliane,
habe mir soeben deine Tabelle angeschaut
probiere mal in der Spalte H
ersetzte
WENN(G2>0;D2*(E2*F2*G2);D2*(E2*F2))
durch
PRODUKT(E2;F2;G2)*D2

und
in der Spalte H
H2/D2
durch
WENN(ISTFEHLER(K2/SUMMEWENN(D2;">0";D2));0;(K2/SUMMEWENN(D2;">0";D2)))

Gruss
Juie


Bild


Betrifft: AW: Nachtrag
von: Juliane
Geschrieben am: 18.11.2003 14:51:01

Kann das leider erst heute abend ausprobieren. Melde mich wieder. Vielen Dank erstmal! Ich denke, dies müßte klappen.
Juliane


Bild


Betrifft: AW: Nachtrag
von: Juliane
Geschrieben am: 18.11.2003 15:34:16

Hat Funtioniert. Auf das naheliegendste hätte ich auch kommen können! Manchmal denkt frau einfach zu kompliziert.
Danke!


Bild


Betrifft: AW: Nachtrag
von: Juie
Geschrieben am: 18.11.2003 16:01:34

Hallo Juliane

kein Grund zur Selbstkritik.
Was glaubst du wie oft sich "mann" selbst im Weg steht.

Gruss Uwe


Bild

Beiträge aus den Excel-Beispielen zum Thema " Summe bei Leerzeilen"