Mal wieder SVERWEIS

Bild

Betrifft: Mal wieder SVERWEIS
von: Martin
Geschrieben am: 01.12.2003 15:15:05

Hallo Excel-Gemeinde,

das leidige Thema SVERWEIS:

Habe 2 Spalten, wobei in der ersten Spalte (A) Zahlenreihen mit folgender Formatierung vorkommen: z.B. 16-05-0001 oder 17-10-1003 oder 14-50-5041 usw.

In der zweiten (Spalte B) prüfe ich ganz einfach, ob irgendwelche doppelte Zahlen vorkommen (Formel in B2:=WENN(A2=0;0;WENN(A2=A1;1;0))

Nun klappt aber mein SVERWEIS leider nicht, der mir anzeigen soll, welche Zahl doppelt vorhanden ist (Formel: =SVERWEIS(1;A1:B3500;1)

Bin zu blöde, den Fehler zu finden! Habt Ihr eine Idee?

Danke und Gruß
Martin

Bild


Betrifft: AW: Mal wieder SVERWEIS
von: Holger
Geschrieben am: 01.12.2003 15:24:17

in welche Spalte soll der SVerweis??


Bild


Betrifft: AW: Mal wieder SVERWEIS
von: Martin
Geschrieben am: 01.12.2003 15:27:23

Hallo Holger,

das Ergebnis soll in C1 stehen, aber ich glaube, das Problem liegt daran, dass die Suche ausschließlich nach rechts und nicht nach links funktioniert, oder?


Bild


Betrifft: AW: Mal wieder SVERWEIS
von: Holger
Geschrieben am: 01.12.2003 15:36:45

Warum versuchst du nicht.
=wenn(A2=A1;"Doppelt";0)


Bild


Betrifft: AW: Mal wieder SVERWEIS
von: Martin
Geschrieben am: 01.12.2003 15:38:37

was mach ich dann z.B. in zeile 3500??? bin dann ständig dabei, den ganzen bildschirm nach dem wort "doppelt" abzusuchen!


Bild


Betrifft: AW: Mal wieder SVERWEIS
von: Holger
Geschrieben am: 01.12.2003 15:43:38

willst du die Doppelten löschen oder damit weiterarbeiten?
Zum Löschen kannst du ja durch kopieren und Inhalte einfügen anschließend sortieren lassen nach der Spalte oder mit Autofilter nur die "Doppelten anzeigen lassen.


Bild


Betrifft: SVERWEIS nach links
von: FCH
Geschrieben am: 01.12.2003 15:44:29

Hi,

geht so:

=INDEX(A1:A3500;VERGLEICH(1;B1:B3500;0))

Gruß
FCH


Bild


Betrifft: Danke FCH!!! Jetzt funzts
von: Martin
Geschrieben am: 01.12.2003 15:57:05

...


Bild


Betrifft: AW: Mal wieder SVERWEIS
von: Mac4
Geschrieben am: 01.12.2003 15:52:28

Hallo Martin,

folgende Matrixformel in C1 und runterkopieren - sie listet Dir die doppelten Einträge auf!

{=WENN(ZEILEN($1:1)>ZÄHLENWENN($B$1:$B$3500;1);"";INDEX($A$1:$A$3500;KKLEINSTE(WENN((B$1:B$3500=1);ZEILE($1:$3500));ZEILEN($1:1))))}

Marc


Bild


Betrifft: Danke Marc, funzt auch ;-)
von: Martin
Geschrieben am: 01.12.2003 15:58:13

...


Bild

Beiträge aus den Excel-Beispielen zum Thema " Mal wieder SVERWEIS"