Werte statt Calculate

Bild

Betrifft: Werte statt Calculate
von: Lorenz K.
Geschrieben am: 05.12.2003 18:04:51

Hallo zusammen!
Wie ist es möglich statt Formel gleich das Ergebnis einzusetzen?


If Target.Column = 14 Then
Range(Cells(6, 15), Cells(6, 15)).Copy Cells(Target.Row, 15)
For Each Zelle In BereichV8
If Zelle.HasFormula Then Zelle.Calculate
Next
End If


Was lustiges gefällig? so Hab ich`s probiert:
For Each Zelle In BereichV8
If Zelle.Value >0 Then Zelle.Value = Zelle.Value
PS:
Calculate ist notwendig, da xlCalculation=Manuell

Gruß Lorenz K.

Bild


Betrifft: AW: Werte statt Calculate
von: PeterW
Geschrieben am: 05.12.2003 18:59:23

Hallo Lorenz,

wenn man wüsste, was das für Formeln sind ließe sich die Berechnung vielleicht direkt im Code durchführen. Könntest du mal eine Beispieltabelle posten?

Gruß
Peter


Bild


Betrifft: AW: Werte statt Calculate
von: Lorenz K.
Geschrieben am: 05.12.2003 19:26:27

Hi Peter!
Solche und ähnliche formeln werden kopiert!

=WENN(WOCHENTAG($B$1)=7;0;WENN(UND(WOCHENTAG($B$1)=2;INDIREKT("'"&TAG($B$1)-1&".'!"&"N"&ZEILE())=0);INDIREKT("'"&TAG($B$1)-3&".'!"&"N"&ZEILE());INDIREKT("'"&TAG($B$1)-1&".'!"&"N"&ZEILE())))
oder
=WENN(SoFt=1;SUMME(($G6=BE$4)*SUMME($GA6*24;SUMME(TEXT("06:00";"HH:MM");-$E6)*24);($J6=BE$4)*$GB6*24;($M6=BE$4)*$GC6*24;($R6=BE$4)*$GD6*24;($U6=BE$4)*$GE6*24;$AJ6);SUMME(($R6=BE$4)*$GD6*24;($U6=BE$4)*$GE6*24;($G6=BE$4)*SUMME(TEXT("06:00";"HH:MM");-$E6)*24))
oder
=WENN(SoFt=0;SUMME(($G6=BE$4)*SUMME(WENN($GA6=0;0;SUMME($GA6*24;-(TEXT($F6;"HH:MM")>="06:00")*SUMME(TEXT("06:00";"HH:MM");-$E6)*24)));($J6=BE$4)*$GB6*24;($M6=BE$4)*$GC6*24);0)


Ich glaube das ist ein bisschen zu heavy für`n CODE.
Grüße Lorenz


Bild


Betrifft: AW: Werte statt Calculate
von: PeterW
Geschrieben am: 05.12.2003 19:41:03

Hallo Lorenz,

stimmt, das wäre etwas zu viel Aufwand.

Nur eine Idee, nicht getestet:
If Zelle.HasFormula Then
Zelle.Calculate
Zelle = Zelle.Value
End If

Gruß
Peter


Bild

Beiträge aus den Excel-Beispielen zum Thema " Wert mit Checkbox übergeben"