Microsoft Excel

Herbers Excel/VBA-Archiv

Formelproblem

Betrifft: Formelproblem von: Bernd
Geschrieben am: 12.08.2004 10:35:47

Hallo

Ich habe ein kleines Formelproblem, welches ich in der Tabelle aufgeführt habe.
Tabelle siehe: https://www.herber.de/bbs/user/9526.xls


Danke schon mal im voraus.
Gruß Bernd

  


Betrifft: AW: Formelproblem von: Andreas Walter
Geschrieben am: 12.08.2004 10:46:12

1. Wie kann ich, wenn ich unter "Helfer" eine "1" eingebe, mir die "Stunden" anzeigen lassen wenn "Uhrzeit (von)" und "Uhrzeit ( bis)" konstant ist ?
2. Wie kann ich die Felder "Stunden" addieren, ohne jede einzelne Zelle anklicken/eingeben zu müssen, und mir das Ergebnis in"Stunden (gesamt)" anzeigen lassen ?
3. Wie mache ich es, das die Tabelle rechts endet und ich nicht immer "durchschießt" ?


Zu 3: Die Spalten AP bis IV (IV ist max Spalte) markieren und mit der rechten Maustaste "Ausblenden".

Zu 1: Du hast in Feld I2 die Formel =SUMME(H2-G2)
Da reicht m.E. nur =H2-G2
Aber ansonsten verstehe ich die Frage nicht.
Willst Du, dass etwas in G2 und H2 eingetragen wird, wenn in J2 eine "1" eingegeben wird.
Dann folgende Formel in G2
=WENN(J2=1;Zeit(12;0;0);Zeit(0;0;0))

Zu 2: Du hast =SUMME(I2+O2) schon =I2+O2 würde auch reichen. Du hast schon die Summe

Irgendwie komme ich nicht mit


  


Betrifft: AW: Formelproblem von: Bernd
Geschrieben am: 12.08.2004 10:58:12

O.K. ich muß zugeben das ich habe mich verkehrt ausgedrückt.
Das Hauptproblem: Wie mache ich es das ich z.B. jede dritte Zelle in der waagerechte addiere ohne jede Zelle eingeben/anklicken zu müssen.

Gruß Bernd


  


Betrifft: AW: Formelproblem von: Andreas Walter
Geschrieben am: 12.08.2004 11:13:08

- O.K. ich muß zugeben das ich habe mich verkehrt ausgedrückt.
Einverstanden

- Das Hauptproblem: Wie mache ich es das ich z.B. jede dritte Zelle in der waagerechte addiere ohne jede Zelle eingeben/anklicken zu müssen.
Auch nicht viel besser.
Wenn Du z.B.
B2, B3 und B4 zusammenaddieren willst un das Ergebnis in B5 haben möchtest, schreibst DU
=SUMME(B2:B4)
in B5 und die Summe wird errechnet.
Wenn Du diese Formel mit STRG-C/STRG-V in B9 kopierst, wird die formel AUTOMATISCH geändert
und zwar in
=SUMME(B6:B8)
Hilft das vielleicht?


  


Betrifft: AW: Formelproblem von: Bernd
Geschrieben am: 12.08.2004 11:18:47

Hilft nicht so ganz!
Ich möchte A1,D1,G1,J1, usw addieren, und mir das Ergebnis in B3 anzeigen lassen.

Gruß Bernd

Danke schon mal für Deine Mühe


  


Betrifft: AW: Formelproblem von: Andreas Walter
Geschrieben am: 12.08.2004 11:26:47

Da fällt mir nichts ein,
aber ich glaube es gibt Spezialisten, die sowas zaubern können.
Daher mache ich den Thread "noch offen"


  


Betrifft: jede dritte Spalte addieren von: WF
Geschrieben am: 12.08.2004 11:38:10

Hi,

=SUMMENPRODUKT((REST(SPALTE(1:1)-1;3)=0)*1:1)

Salut WF


  


Betrifft: AW: Formelproblem von: Panicman
Geschrieben am: 12.08.2004 11:55:06

Hallo Bernd,

für deine Datei würde doch reichen:
D2 =SUMMEWENN($1:$1;"Stunden";2:2)
E2 =SUMMEWENN($1:$1;"Helfer";2:2)
und runterkopieren

Gruß
Holger