Microsoft Excel

Herbers Excel/VBA-Archiv

Daten aus Tabelle 1 in Tabelle 2 übertragen.

Betrifft: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Steffi
Geschrieben am: 14.08.2004 18:10:03

Hallo Ihrs!
Auch ich habe ein Problem. Möchte es gerne einmal schildern. Vielleicht gibt es ja doch (vermutlich gibt es für alle Probleme eine Lösung ;o) ) eine Lösung:

In einem Tabellenblatt habe ich in Spalte A1 bis A17 Kontonummern. In Spalte B1 bis B17 eine entsprechende Verwendungsnummer. In Spalte C1 bis C17 stehen die jeweiligen angefallene Kosten.
In einem anderen Tabellenblatt ist in Spalte A2 bis A... (mit zusätzlilch anderen Werten) stehen die Kontonummern. In Zeile B1 bis B... sind die Verwendungsnummern. (mit wiederrum anderen Werten/Zeichen da dazwischen).

Gibt es nun eine Möglichkeit, dass die jeweiligen Kosten aus Tabelle 1 in den richtig zugeordneten Feldern der Tabelle 2 anhand eines Befehls (sei es über VBA oder mit einer sonstigen Excelformel) übertragen werden?

Kompliziert? Jawohl. Weiß leider nicht, wie ich mich anders ausdrücken könnte.

Falls doch jemand Ahnung hat, was ich mitunter damit meine und auch noch Hilfe weiß, bin ich vorab schon sehr dankbar dafür!

Schöne Gruesse

Steffi

  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Nenesis
Geschrieben am: 14.08.2004 18:36:01

Hallo Steffie

Mit einer Formel geht das so

=Tabelle1!A1
In das Tabelle blatt und zelle einfugen, wo du es hin kopieren willst

Gruß
Nenesis


  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: FP
Geschrieben am: 14.08.2004 18:36:22

Hallo Steffi,

meinst Du das so?

Tabelle1
 ABC
111 €     633,47
212 €     718,03
311 €     922,42
421 €     291,72
522 €     153,42
631 €     920,59
732 €     254,94
833 €     926,72
941 €     524,88
1051 €     968,73
1152 €       40,48
1253 €     697,91
1354 €     338,52
1461 €     734,68
1562 €     442,37
 
Tabelle2
 ABC
1KontoVerwKosten
211 €  1.555,89
312 €     718,03
414 €            -  
521 €     291,72
625 €            -  
731 €     920,59
832 €     254,94
933 €     926,72
1071 €            -  
1151 €     968,73
1252 €       40,48
1353 €     697,91
1454 €     338,52
1561 €     734,68
1662 €     442,37
Formeln der Tabelle
C2 : =SUMMENPRODUKT((A2&B2=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C3 : =SUMMENPRODUKT((A3&B3=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C4 : =SUMMENPRODUKT((A4&B4=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C5 : =SUMMENPRODUKT((A5&B5=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C6 : =SUMMENPRODUKT((A6&B6=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C7 : =SUMMENPRODUKT((A7&B7=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C8 : =SUMMENPRODUKT((A8&B8=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C9 : =SUMMENPRODUKT((A9&B9=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C10 : =SUMMENPRODUKT((A10&B10=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C11 : =SUMMENPRODUKT((A11&B11=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C12 : =SUMMENPRODUKT((A12&B12=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C13 : =SUMMENPRODUKT((A13&B13=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C14 : =SUMMENPRODUKT((A14&B14=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C15 : =SUMMENPRODUKT((A15&B15=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
C16 : =SUMMENPRODUKT((A16&B16=Tabelle1!A$1:A$15&Tabelle1!B$1:B$15)*Tabelle1!C$1:C$15)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Steffi
Geschrieben am: 15.08.2004 07:38:50

Gudn Morgen,

danke für die schnelle Reaktionen!

@Nemesis: bei deinem Vorschlag darf ich alle Zellen manuell suchen gehen um die Beträge Stück für Stück zu kopieren? Nicht? Nicht unbedingt das, was ich mir vorgestellt habe ;)
----
@FB: Du gehst davon aus, dass die 2. Tabelle auch wie die erste Tabelle in senkrechter Konstellation angeordnet ist. Die Kontonummern sind allerdings senkrecht, die Verwendungszwecknummern waagerecht angeordnet. Also bringt mir Dein Vorschlag leider auch nichts. (Obwohl ansonsten recht interessant!)

Ich werds mal weiter probieren.

Dankeschön trotzdem

Steffi


  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Erich M.
Geschrieben am: 15.08.2004 07:49:48

Hallo Steffi,

sorry, aber Deine Antwort stimmt mit der Fragestellung nicht ganz überein, wo die
Verwendungszwecke stehen. Am besten Du lädst mal eine Musterdatei hoch, dann wirds klarer.

mfg
Erich


  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Steffi
Geschrieben am: 15.08.2004 12:33:02







Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Erich M.
Geschrieben am: 16.08.2004 06:42:20

Hallo Steffi,

Du müsstest die Formel von FP betreffend der Verwendungszwecknr. $B$1:$Q$1 entsprechend
anpassen.

mfg
Erich


  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Steffi
Geschrieben am: 16.08.2004 18:31:52

Hi Erich,

das sollte ich wohl verstehen, schätze ich mal?! Nun jah, hab das Kapitel für mich abgeschlossen.
Dank Dir für Dein Mitdenken!

Gruesse, Steffi


  


Betrifft: AW: Daten aus Tabelle 1 in Tabelle 2 übertragen. von: Erich M.
Geschrieben am: 18.08.2004 19:52:11

Hallo Steffi,

danke für die Rückmeldung - aber ist das Problem jetzt gelöst?
(auch später fürs Archiv)

mfg
Erich


 

Beiträge aus den Excel-Beispielen zum Thema "Daten aus Tabelle 1 in Tabelle 2 übertragen."