Microsoft Excel

Herbers Excel/VBA-Archiv

Formel zeigt O,OO Werte was mache ich falsch.

Betrifft: Formel zeigt O,OO Werte was mache ich falsch. von: marc
Geschrieben am: 15.08.2004 14:20:36

hallo zusammen,
ich habe mir 'ne Grafischetendenz gebastelt

=WENN(C12>C19;"ö";WENN(C12<C19;"ø";"ð")) '<--Wingdings "Pfeil"

=RUNDEN(MITTELWERT($X$3:$X$6);0) '<-- Formel steht in Zelle "C12"

nun das Ergebnis in Zelle "C12" wird als 0,00 ausgegeben !?
ich moechte aber die Werte aus dem Bereich ("X3:X6") in "C12" sehen.

0,39 X3
0,00 X4
0,25 X5
0,17 X6 = Mittelwert 0,20

wer kann mir helfen.
marc.


  


Betrifft: AW: Formel zeigt O,OO Werte was mache ich falsch. von: DieterB
Geschrieben am: 15.08.2004 14:24:57

nimm mal die $ raus

gruß

DieterB


  


Betrifft: AW: Formel zeigt O,OO Werte was mache ich falsch. von: marc
Geschrieben am: 15.08.2004 14:31:41

hallo Dieter,
ich habe das Dollarzeichen in der Mittelwertformel entfernt und es hat sich nichts veraendert.
Aus versehen habe ich die Zahl "0" die in der Formel am Ende steht mit "1" ueberschrieben und somit das gewuenschte Ergebnis bekommen.

danke marc.


  


Betrifft: Das ist korrekt..... von: Ramses
Geschrieben am: 15.08.2004 14:27:10

Hallo

schau dir mal die beiden Formeln an, dann weisst du es

Tabelle1
 ABC
10.390.39 
20.000.00 
30.250.25 
40.170.17 
5   
60.000.20 
Formeln der Tabelle
A6 : =RUNDEN(MITTELWERT(A1:A4);0)
B6 : =RUNDEN(MITTELWERT(B1:B4);2)
 




Gruss Rainer


  


Betrifft: AW: Das ist korrekt..... von: marc an Ramses.
Geschrieben am: 15.08.2004 14:35:22

Hallo Rainer,

also die "1" ist falsch wie ich sehe?

o.k ich uebernehme deine Formel

danke marc.


  


Betrifft: AW: Das ist korrekt..... von: Ramses
Geschrieben am: 15.08.2004 14:45:00

hallo

Von welcher 1 redest du ?

Öffne mal die EXCEL Hilfe und gib als Suchbegriff "RUNDEN" ein.
Dort in den Parametern wird dir erklärt was die Zahl nach dem Semikolon in der Formel bewirkt.

Wenn du als Ergebnis NUR ZAHLEN KLEINER NULL HAST, und du formatierst mit dem Parameter ";0" das Ergebnis der Funktion Mittelwert NUR AUF ZAHLEN GRÖSSER 0, dann musst du dich doch nicht wundern, wenn keine Dezimalergebisse angezeigt werden !!!

Deshalb habe ich in meiner Formel die ";2" damit als Ergebnis noch MINDESTENS 2 Nachkommastellen angezeigt werden.

Gruss Rainer


  


Betrifft: AW: Das ist korrekt..... von: Ich bedanke mich.
Geschrieben am: 15.08.2004 14:48:57

Rainer,

habe verstanden und bis zum naechsten mal.

-
marc.


  


Betrifft: Merci :-) Geschlossen. o.T. von: Ramses
Geschrieben am: 15.08.2004 14:58:56

...


 

Beiträge aus den Excel-Beispielen zum Thema "Formel zeigt O,OO Werte was mache ich falsch."