Microsoft Excel

Herbers Excel/VBA-Archiv

Passwort in Funktion / Auslesen alfa num Werte

Betrifft: Passwort in Funktion / Auslesen alfa num Werte von: Wolfgang
Geschrieben am: 16.08.2004 09:58:32

Hallo Excel-Profis,
ich möchte mich mit zwei Fragen an Euch wenden und hoffe auf Eure Hilfe:

1. "Herber sei Dank" arbeite ich seit heute mit folgender Funktion um die Anzahl des Wertes "1" in einer anderen Tabelle abzufragen.

=SUMMENPRODUKT(('J:\ZBS\STATISTI\BOCK\[2004UB.xls]Tabelle1'!$E$20:$E$300=1)*('J:\ZBS\STATISTI\BOCK\[2004UB.xls]Tabelle1'!$E$20:$E$300=1))

Da die Tabellen durch ein mir bekanntes Passwort geschütz sind, ich werde ich bei der Aktualisierung jedoch 10x aufgefordert das Passwort einzugeben. Das funktioniert aber nervt.
Kann man das Passwort in der Funktion SUMMENPRODUKT hinterlegen und wie ist die richtige Syntax?

2. Welche Funktion ist in der Lage nicht ausschliesslich nummerische Werte (Anzahl des Wertes: "1 Scheel") aus einer anderen, geöffneten Tabelle auszulesen. (ZÄHLENWENN liefert die Fehlermeldung "WERT!", SUMMENPRODUKT ist nur für nummerische Werte)?

Ich danke Euch für Eure Hilfe.
Gruss
Wolfgang

  


Betrifft: Passwort in Funktion / Auslesen alfa num Werte von: Beate Schmitz
Geschrieben am: 16.08.2004 10:08:56

Hallo Wolfgang,


zu 1):
Vielleicht per Worksheet_Calculate Makro den Passwortschutz der anderen Datei aufheben und am Ende wieder setzen. Aber im Code wäre dann ja das Passwort der anderen Datei ablesbar.


zu 2):
=ZÄHLENWENN([Mappe2]Tabelle1!$A$1:$A$10;"1 Scheel")
ZÄHLENWENN und SUMMENPRODUKT funktionieren mit nicht-nummerischen Werten, du musst den Suchbegriff aber in Anführungszeichen setzen.
Dateinamen/Blattnamen/Zellbereich natürlich anpassen.

Gruß,
Beate


  


Betrifft: AW: Passwort in Funktion / Auslesen alfa num Werte von: Wolfgang
Geschrieben am: 16.08.2004 10:22:27

Hallo Beate,
danke für Deine Hinweise.
1. Am liebsten hätte ich das Passwort in die Funktion eingebaut, da die Abfragetabelle nur mir zugänglich ist kein Sicherheitsrisiko.

2. Die Anführungsstriche hatte ich schon drin! Die Funktion sah bis letzte Woche so aus:

=ZÄHLENWENN('J:\ZBS\ZENTRALE\LISTEN\[TK_PO_TE2004.xls]Tageskarte'!$D$3:$D$30000;"=1 Scheel")

Fehlermeldung: #WERT!
Gruss
Wolfgang


  


Betrifft: AW: Passwort in Funktion / Auslesen alfa num Werte von: Beate Schmitz
Geschrieben am: 16.08.2004 10:34:49

Hallo Wolfgang,

Zu 1):
dann müsstest du du Funktion SUMMENPRODUKT komplett benutzerdefiniert nachbauen (ich kann das nicht). Und in der Funktion müsste ja das Passwort erscheinen. Dann macht es doch keinen Unterschied, ob es im Worksheet_Calculate Makro auftaucht und du sparst dir den Funktionsnachbau.

Zu 2):
Also deine ZÄHLENWENN-Formel hat mal funktioniert? Hat sich vielleicht der Pfad/Dateiname/Blattname/Zellbereich deiner Quelldatei geändert? Sonst habe ich auch keine Idee.

Gruß,
Beate


  


Betrifft: Es klapper! von: Wolfgang
Geschrieben am: 16.08.2004 10:42:35

Hallo Beate,
zu 2. ich habe gerade einen Fehler in der Syntax der Funktion SUMMENPRODUKT bei mir festgestellt. Bei ZÄHLENWENN habe ich immer ein Semikolon vor der Abfrage gehabt - das muss man scheinbar bei SUMMENPRODUKT weglassen. Kopierfehler sorry! - So ist das nun mal mit Dilettanten.
Herzlichen Dank für Deine Hilfe!!!
Gruss
Wolfgang


 

Beiträge aus den Excel-Beispielen zum Thema "Passwort in Funktion / Auslesen alfa num Werte"