Microsoft Excel

Herbers Excel/VBA-Archiv

Teile von Zahlen entfernen

Betrifft: Teile von Zahlen entfernen von: Michael Jäger
Geschrieben am: 17.08.2004 15:38:03

Hallo Excel User,

mein Problem: Zur Dekodierung von Lieferanten-Informationen, wollte ich eine kleine Tabelle machen, in dem die Codierung eingegeben wird und dann die Echtwerte angezeigt werden.
BSP: Codierung 04257
-bedeutet EK: erste und letzte Stelle weg, dann durch 100 teilen = 4,25
VK: erste und letzte Stelle anordnen und ,90 anhängen = 07,90
Den Ek-Teil habe ich schon fertig (einfach mit der Teil-Funktion). Leider habe ich bis jetzt keinen Schimmer, wie ich die erste und die letzte Ziffer wieder zu der Zahl zusammenbekomme. Bei Addition mag dies im Beispiel noch funktionieren, aber ich habe auch 6 (Bsp.:841565)bzw. 7-Stellige (1155950) Codierungen.
Bei der 6-stelligen Zahl bedeutet das erste(8) und letzte(5) mit angehängten ,90 = 85,90.
Bei der 7-stelligen Zahl bedeutet das erste(11) und letzte(0) mit angehängten ,90 = 110,90.

Für einen Lösungsansatz wäre ich euch sehr dankbar.

mfg
Michael

  


Betrifft: AW: Teile von Zahlen entfernen von: Bertram
Geschrieben am: 17.08.2004 15:52:14

Hallo Michael,

hab ich das so richtig verstanden:
In A16 dein Code
In B16 folgende Formel:
=WENN(LÄNGE(A16)=7;LINKS(A16;2)&RECHTS(A16;1)&",90";LINKS(A16;1)&RECHTS(A16;1)&",90")

Gruß
Bertram


  


Betrifft: ... oder als Werte zum weiteren Verarbeiten von: heikoS
Geschrieben am: 17.08.2004 16:08:04

=WENN(LÄNGE(A1)=7;WERT(LINKS(A1;2)&RECHTS(A1;1))+0,9;WERT(LINKS(A1;1)&RECHTS(A1;1))+0,9)

Gru? Heiko


  


Betrifft: AW: ... oder als Werte zum weiteren Verarbeiten von: Bertram
Geschrieben am: 17.08.2004 16:11:10

Hi Heiko,

weiteres Verarbeiten geht bei meiner Version aber auch.

Gruß
Bertram


  


Betrifft: AW: ... oder als Werte zum weiteren Verarbeiten von: heikoS
Geschrieben am: 17.08.2004 16:15:35

Hi Bertram,

stimmt, allerdings müssen dann die Texte in der weiteren Verarbeitung zu Werten gemacht werden. Ist glaube ich eine Geschmacksfrage ... :-)

Gruß Heiko


  


Betrifft: AW: ... oder als Werte zum weiteren Verarbeiten von: Michael Jäger
Geschrieben am: 17.08.2004 16:29:11

Vielen Dank,
die Formeln funktionieren prima.


  


Betrifft: =(LINKS(A1;1+(LÄNGE(A1)-6))&RECHTS(A1)+0,9)*1 von: Panicman
Geschrieben am: 17.08.2004 16:13:58




  


Betrifft: =ERSETZEN(A1;2+(LÄNGE(A1)=7);4;)+0,9 von: Boris
Geschrieben am: 17.08.2004 16:26:31

;-)


  


Betrifft: @ Boris von: Panicman
Geschrieben am: 17.08.2004 16:32:50

Hallo Boris,

schön mal wieder was von dir zu lesen.
In weiser vorraussicht ist meine Formel zwar länger,
aber rechnet auch bei 5stelligen Zahlen und
bei mehr als 7stelligen Zahlen richtig.

Gruß
Holger

P.S. Ich habe dir letzte Woche ne E-Mail geschickt.
Melde dich doch mal heute abend per mail


  


Betrifft: AW: @ Holger von: Boris
Geschrieben am: 17.08.2004 16:40:31

Hi Holger,

bin heute Abend aber erst sehr spät zu Hause - aber ich melde mich :-)

Grüße Boris


 

Beiträge aus den Excel-Beispielen zum Thema "Teile von Zahlen entfernen"