Microsoft Excel

Herbers Excel/VBA-Archiv

IF Function nur 7 mal in einer Formel?!

Betrifft: IF Function nur 7 mal in einer Formel?! von: Florian
Geschrieben am: 18.08.2004 17:40:03

Hallo,
ich ziehe aus einer Pivot Tabelle die Monate mittels einer IF Function, wobei die Monate (in der Pivot Tabelle) nummeriert sind: 1 fuer Jan, 2 fuer Feb,... 12 fuer Dec. Ausserhalb moechte ich aber die Abkuerzungen Jan, Feb... praesentiert bekommen (in einer Zelle). Dies funktioniert auch bis Jul, danach nicht mehr, da Excel nur 7 If Functions innerhalb einer If Function zulaesst, so'n Mist!!!!
Im Anhang habe ich das Beispiel eingefuegt.
Hat jemand vielleicht eine Ahnung wie man das machen koennte, alle 12 Monate + die Summe (All) in einer Zelle wiederzuspiegeln???????
Viele Gruesse,
Florian

  


Betrifft: IF Function nur 7 mal in einer Formel?! von: Florian
Geschrieben am: 18.08.2004 17:44:10

sorry,hat mit dem Hochladen erst nicht geklappt, hier ist es aber:
https://www.herber.de/bbs/user/9784.xls


  


Betrifft: AW: IF Function nur 7 mal in einer Formel?! von: PeterW
Geschrieben am: 18.08.2004 18:08:53

Hallo Florian,

in C1 die Formel =DATUM(1;B1;1) und C1 formatieren benutzerdefiniert als MMM.

Gruß
Peter


  


Betrifft: AW: IF Function nur 7 mal in einer Formel?! von: Florian
Geschrieben am: 18.08.2004 18:44:23

Hallo Peter,
super, danke fuer den Tipp, klappt prima.
ABER (typisch Excel, hat man eine Sache geloest, kommt gleich das naechste Problem)
auf die Zelle in der jetzt das Monatskuerzel steht, bezieht sich ein VLOOKUP (SVERWIES) Befehl und ich glaube der erkennt die formatierte Zelle nicht an. Formatiere ich die Zelle als 'General'(Allgemein)bekomme ich eine Zahl,was natuerlich nicht geht
Weisst du dafuer noch ne Loesung????
Gruss Florian


  


Betrifft: AW: IF Function nur 7 mal in einer Formel?! von: PeterW
Geschrieben am: 18.08.2004 18:51:19

Hallo Florian,

warum benutzt du für den Sverweis nicht B1?

Gruß
Peter


  


Betrifft: AW: IF Function nur 7 mal in einer Formel?! von: PeterW
Geschrieben am: 18.08.2004 19:01:45

Hallo Florian,

hab ich wohl falsch verstanden. Wenn du die Monatskürzel für den Sverweis brauchst geht das mit:
=SVERWEIS(TEXT(C1;"MMM");Matrix;Spaltenindex;Bereich_Verweis)

Gruß
Peter


  


Betrifft: AW: IF Function nur 7 mal in einer Formel?! von: Florian
Geschrieben am: 18.08.2004 20:15:04

Hallo Peter,
mal ganz ehrlich, woher weiss man sowas,ist doch unglaublich.Ich kommuniziere mein Problem, es kommt eine Loesung, ich tipp die ein und es klappt. Einfach unglaublich. Bin jetzt fertig mit meiner Aufgabe, dank dieser Homepage und deiner Hilfe sowie der Hilfe einiger anderer sehr erfahrener Excelprofis.
Vielen, vielen Dank,
Florian