Microsoft Excel

Herbers Excel/VBA-Archiv

Alle Datum in einem Zeitintervall dyn. auflisten

Betrifft: Alle Datum in einem Zeitintervall dyn. auflisten von: Proximus
Geschrieben am: 20.08.2004 16:11:20

Hallo,

ich wollte gern alle Datum eines Zeitintervalls untereinander so auflisten, dass sie auch fals erforderlich Jahresübergreifend sind.

Anfang: 6.4.2004
Ende: 12.3.2005

6.4.2004
7.4.2004
.
.
.
31.12.2004
01.01.2005
02.01.2005
.
.
.
12.03.2005

Ich hoffe ihr habt mich verstenden und könnt mir helfen!

DANKE im vorraus!

Gruss Proximus

  


Betrifft: AW: Alle Datum in einem Zeitintervall dyn. auflisten von: harry
Geschrieben am: 20.08.2004 16:52:16

hi,
so in der art?
https://www.herber.de/bbs/user/9886.xls

liebe grüße,
harry


  


Betrifft: AW: Alle Datum in einem Zeitintervall dyn. auflisten von: ransi
Geschrieben am: 20.08.2004 16:54:56

hallo

oder so:
wobei in a1 dein start und in a2 dein enddatum steht

Public
Sub test()
Dim i As Integer
For i = 1 To [a2] - [a1]
Cells(2 + i, 1).Value = [a1] + i
Next
End Sub

ransi


  


Betrifft: AW: Alle Datum in einem Zeitintervall dyn. auflisten von: HermannZ
Geschrieben am: 20.08.2004 18:17:49

Hallo Proximus,

oder mit formel:

DatumZeitMuster
 AB
738AusgangsdatumEnddatum
73901.06.200411.06.2004
74002.06.2004 
74103.06.2004 
74204.06.2004 
74305.06.2004 
74406.06.2004 
74507.06.2004 
74608.06.2004 
74709.06.2004 
74810.06.2004 
74911.06.2004 
750  
751  
752  
753  
Formeln der Tabelle
A740 : =WENN(A739<$B$739;A739+1;"")
A741 : =WENN(A740<$B$739;A740+1;"")
A742 : =WENN(A741<$B$739;A741+1;"")
A743 : =WENN(A742<$B$739;A742+1;"")
A744 : =WENN(A743<$B$739;A743+1;"")
A745 : =WENN(A744<$B$739;A744+1;"")
A746 : =WENN(A745<$B$739;A745+1;"")
A747 : =WENN(A746<$B$739;A746+1;"")
A748 : =WENN(A747<$B$739;A747+1;"")
A749 : =WENN(A748<$B$739;A748+1;"")
A750 : =WENN(A749<$B$739;A749+1;"")
A751 : =WENN(A750<$B$739;A750+1;"")
A752 : =WENN(A751<$B$739;A751+1;"")
A753 : =WENN(A752<$B$739;A752+1;"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann
Gruß Hermann


 

Beiträge aus den Excel-Beispielen zum Thema "Alle Datum in einem Zeitintervall dyn. auflisten"