Microsoft Excel

Herbers Excel/VBA-Archiv

swerweis in allen spalten

Betrifft: swerweis in allen spalten von: Jürgen
Geschrieben am: 28.08.2004 23:51:03

Hallo,

ich komme nicht weiter...

Ich möchte nach Daten in einer recht großen Matrix suchen und wenn die daten gefunden wurden, dann soll die Überschrift ausgegeben werden

https://www.herber.de/bbs/user/10228.xls

Grüße
Jürgen



  


Betrifft: AW: swerweis in allen spalten von: andre
Geschrieben am: 29.08.2004 07:32:44

Hallo Jürgen,
siehe
http://www.excelformeln.de/formeln.html?welcher=58
Formeln:
in D1 den Suchbegriff eingeben, z.B.
Opel
in E1 die Arrayformel (geschweifte Klammern nicht eingeben! Eingabe mit Strg-Shift-Enter abschließen)
{=MIN(WENN(A$2:F$100=D1;ZEILE(2:100)))}
in F1
=VERGLEICH(D1;INDIREKT("A"&E1):INDIREKT("C"&E1);0)
in G1
=INDEX(A1:C1;1;F1)
Du kannst das alles natürlich auch zu einer Formel zusammenfassen und diese dann kommplett als Arrayformel eingeben.


  


Betrifft: AW: swerweis in allen spalten von: Jürgen
Geschrieben am: 29.08.2004 12:56:41

Hallo Andre,

alles super gefunzt.
Besten Dank.

Grüße
Jürgen


  


Betrifft: AW: swerweis in allen spalten von: HermannZ
Geschrieben am: 29.08.2004 13:39:40

hallo Jürgen,

das ganze ohne Array,

Tabelle1
 ABCDE
1ObstAutosStädteOpel 
2ÄpfelOpelBochum  
3BirnenAudiStuttgart  
4BananenVWKassel Autos
Formeln der Tabelle
E4 : =INDEX(A1:C1;1;VERGLEICH(D1;INDIREKT("A"&SUMMENPRODUKT((A2:C100=D1)*(ZEILE(2:100)))):INDIREKT("C"&SUMMENPRODUKT((A2:C100=D1)*(ZEILE(2:100))));0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruß Hermann


 

Beiträge aus den Excel-Beispielen zum Thema "swerweis in allen spalten"