Microsoft Excel

Herbers Excel/VBA-Archiv

Rangfolge mit Beschreibung automatisch sortieren

Betrifft: Rangfolge mit Beschreibung automatisch sortieren von: ralf
Geschrieben am: 01.09.2004 15:37:38

Servus,
ich habe meine Rangfolge erfolgreich erstellt.
Nun benötige ich eine sortierte Tabelle der Rangfolge und deren Bezeichnung.
Ich habe eine 2 Tabelle erstellt, wenn möglich sollte diese automatisch eine sortierte Rangfolge und dazugehörende Bezeichnungen enthalten.
Ich habe bisher herausbekommen, das so etwas mit der Pivot Tabelle möglich sein soll.
Kann mir da jemand helfen?

Ralf

  


Betrifft: mein Vorschlag: von: Günther Oppold
Geschrieben am: 01.09.2004 17:01:16

Hallo Ralf

hier wieder ein Lösungsvorschlag:
Tabelle2 Spalte A ist wieder eine Hilfsspalte und beinhaltet wieder eine Array-Formel


Tabelle1
 ABCD
1  Hilfsspalte 
2Albert0Rang 10
3Boris4Rang 51
4Clausius5Rang 62
5Detlev1Rang 23
6Erich4Rang 54
7Fritz3Rang 45
8Günther6Rang 76
9Hans5Rang 6#ZAHL!
10Iris2Rang 3#ZAHL!
Formeln der Tabelle
C2 : ="Rang "&VERGLEICH(B2;D$2:D$10;0)
D2 : =KKLEINSTE(B2:B10;1)
C3 : ="Rang "&VERGLEICH(B3;D$2:D$10;0)
D3 : {=KKLEINSTE(WENN(B$2:B$10>D2;B$2:B$10);1)}
 
Tabelle2
 ABCD
12Albert0Rang 1
25Detlev1Rang 2
310Iris2Rang 3
47Fritz3Rang 4
53Boris4Rang 5
66Erich4Rang 5
74Clausius5Rang 6
89Hans5Rang 6
98Günther6Rang 7
Formeln der Tabelle
A1 : {=VERGLEICH(KKLEINSTE(Tabelle1!B$2:B$10+ZEILE(Tabelle1!B$2:B$10)/10000;ZEILE());Tabelle1!B$2:B$10+ZEILE(Tabelle1!B$2:B$10)/10000;0)+1}
B1 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!A"&A1));"";INDIREKT("Tabelle1!A"&A1))
C1 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!B"&A1));"";INDIREKT("Tabelle1!B"&A1))
D1 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!C"&A1));"";INDIREKT("Tabelle1!C"&A1))
A2 : {=VERGLEICH(KKLEINSTE(Tabelle1!B$2:B$10+ZEILE(Tabelle1!B$2:B$10)/10000;ZEILE());Tabelle1!B$2:B$10+ZEILE(Tabelle1!B$2:B$10)/10000;0)+1}
B2 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!A"&A2));"";INDIREKT("Tabelle1!A"&A2))
C2 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!B"&A2));"";INDIREKT("Tabelle1!B"&A2))
D2 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!C"&A2));"";INDIREKT("Tabelle1!C"&A2))
A3 : {=VERGLEICH(KKLEINSTE(Tabelle1!B$2:B$10+ZEILE(Tabelle1!B$2:B$10)/10000;ZEILE());Tabelle1!B$2:B$10+ZEILE(Tabelle1!B$2:B$10)/10000;0)+1}
B3 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!A"&A3));"";INDIREKT("Tabelle1!A"&A3))
C3 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!B"&A3));"";INDIREKT("Tabelle1!B"&A3))
D3 : =WENN(ISTFEHLER(INDIREKT("Tabelle1!C"&A3));"";INDIREKT("Tabelle1!C"&A3))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

 

Beiträge aus den Excel-Beispielen zum Thema "Rangfolge mit Beschreibung automatisch sortieren"