Microsoft Excel

Herbers Excel/VBA-Archiv

wenn-Bedingung: ganze Zahl

Betrifft: wenn-Bedingung: ganze Zahl von: Marita
Geschrieben am: 07.09.2004 10:35:35

Hallo!

Ich möchte, dass die wenn-Bedingung nur einen Wert liefert, wenn eine Formel (z.B. B5*B3) eine ganze Zahl ergibt, also in der Form

wenn(B5*B3=ganzzahlig;"Wert liefern";0)

Wie schaffe ich das mit der Bedingung, am besten ohne VBA?
Vielen Dank,
Marita

  


Betrifft: AW: wenn-Bedingung: ganze Zahl von: Mac4
Geschrieben am: 07.09.2004 10:42:07

Hallo Marita,

eine Möglichkeit (Wert steht in A1, zurückzugebener Wert in B1):
=WENN(REST(A1;GANZZAHL(A1))=0;B1;0)

Marc (aus Köln)


  


Betrifft: AW: wenn-Bedingung: ganze Zahl von: ypsilon
Geschrieben am: 07.09.2004 10:42:09

hi Marita
=WENN(GANZZAHL(B3*B5)=B3*B5;"ist ganzzahl";"ist keine")

cu Micha


  


Betrifft: AW: wenn-Bedingung: ganze Zahl von: Marko
Geschrieben am: 07.09.2004 10:44:44

Hi Marita

probier mal
=wenn(B5*B3=Runden(B5*B3;0);"Wert liefern";0)

Gruß Marko


  


Betrifft: Dankeschön! von: Marita
Geschrieben am: 07.09.2004 11:26:26

Das ging ja schnell, und dann noch 3 Antworten, die alle funktionieren!
Danke nochmal!


  


Betrifft: AW: =B3*B5*(REST(B3*B5;1)<0,01) von: FP
Geschrieben am: 07.09.2004 13:11:19

Hi Marita,

damit Du wirklich 3 funktionierende Varianten hast ;-)

Anmerkung: die von Mac4 funktioniert leider nicht immer, weil er auf Rest Null überprüft, und Excel - bzw. besser gesagt der PC - mit Nachkomma-Berechnungen nicht ganz richtig umgehen kann, d.h. anders gesagt: eigentlich kann der PC nur mit Ganzzahlen richtig rechnen...

( es muss daher auf signifikante Stellen geprüft werden )


Servus aus dem Salzkammergut
Franz