Microsoft Excel

Herbers Excel/VBA-Archiv

Monatsnamen in Fremdsprache

Betrifft: Monatsnamen in Fremdsprache von: Jesko
Geschrieben am: 08.09.2004 17:46:50

Hallo an alle Teilnehmer!

Gibt es eine einfache Möglichkeit, Monatsnamen per Formel in einer Fremdsprache auszugeben?

Bsp.:
Inhalt Zelle A1: Januar 2004
gewünscht Zelle B1: January 2004
Die Jahreszahlen müssen mit angegeben werden!

Schon einmal besten Dank!

Jesko

  


Betrifft: AW: Monatsnamen in Fremdsprache von: andre
Geschrieben am: 08.09.2004 19:33:14

Hallo Jesko,
im Prinzip so:

Function Month_Engl(ByRef zelle As Range) As String

If Left(zelle, InStr(1, zelle, " ") - 1) = "Januar" Then _
   Month_Engl = "January " & Right(zelle, 4)
If Left(zelle, InStr(1, zelle, " ") - 1) = "Februar" Then _
   Month_Engl = "February " & Right(zelle, 4)

End Function


Die beiden Zeilen musst Du für die anderen Monate auffüllen. Bei falschen Eingaben kommt natürlich kein oder ein falsches Ergebnis raus. Kannst ja mal probieren, mit Leerzeichen vorn dran oder in der Mitte eins mehr usw.


  


Betrifft: AW: Monatsnamen in Fremdsprache von: Jesko
Geschrieben am: 08.09.2004 23:05:37

Hallo André!

Danke für Deine Antwort. Die Lösung gefällt mir, nur bin ich in VBA erst im Anfangsstadium!! Könntest Du mir daher bitte eine Beispieldatei mit dem VBA-Code erstellen und erläutern, wie ich den Code in die Datei bringe?
Gibt es auch eine Variante über herkömmliche Formeln?

Ich freue mich, wieder von Dir zu hören.
Jesko


  


Betrifft: AW: Monatsnamen in Fremdsprache von: andre
Geschrieben am: 09.09.2004 16:59:40

Hallo Jesko,
dann lassen wir es mal bei den Formeln:
in A1 die Angabe, in B1 diese Formel, in D1:D12 die deutschen Monate und in E1:E12 die Englischen, beide Spalten nach den deutschen Monaten sortiert:
=SVERWEIS(LINKS(A1;FINDEN(" ";A1;1)-1);D1:E12;2)&" "&RECHTS(A1;4)

VBA: mit ALT+F11 in die VBE wechseln, per Menü Einfügen Modul, dort den Code eingeben. Die Function erscheint dann unter benutzerdefiniert ...


  


Betrifft: AW: Monatsnamen in Fremdsprache von: th.heinrich
Geschrieben am: 09.09.2004 21:53:16

guten abend Jesko,

andre hat Dir ja schon erklaert wo die BENUTZERDEFINIERTE-FUNKTION zu plazieren ist.

hier noch ein beispiel.

=my_date("29.3.03") march 29, 2003

Function my_date(datum As Date) As String	
Dim a As Variant	
a = Array("jan", "feb", "mar", "apr", "may", "jun", "jul", "aug", "sep", "oct", "nov", "dec")	
my_date = a(Month(datum) - 1) & " " & Day(datum) & ", " & Year(datum)	
End Function


von Harald

falls Du den tag nicht brauchst, dementsprechend entfernen.

gruss thomas


 

Beiträge aus den Excel-Beispielen zum Thema "Monatsnamen in Fremdsprache"