Microsoft Excel

Herbers Excel/VBA-Archiv

Gewichteter Durchschnitt

Betrifft: Gewichteter Durchschnitt von: philben
Geschrieben am: 13.09.2004 20:59:10

Hallo,

ich habe ein Problem mit dem gewichteten Durchschnitt. Bis jetzt berechne ich ihn so:

=((A1*1)+(A2*2)+(A3*3)+(A4*4)+(A5*5))/15

Das müsste doch auch irgendwie einfacher gehen, oder?

Ich möchte nähmlich auch für 200 Werte den gewichteten Durchschnitt berechnen.

Danke im Vorraus

Philben

  


Betrifft: AW: Gewichteter Durchschnitt von: Frank Kabel
Geschrieben am: 13.09.2004 21:35:46

Hi
wenn Deine Gewichtungsfaktoren in Spalte B stehen nutze
=SUMMENPRODUKT(A1:A5;B1:B5)/SUMME(B1:B5)

Frank


  


Betrifft: AW: Gewichteter Durchschnitt von: philben
Geschrieben am: 13.09.2004 22:41:04

Danke, ich probier es mal aus.


  


Betrifft: Mit Hilfsspalte ? von: ransi
Geschrieben am: 13.09.2004 21:36:38

hallo philben

was besseres fällt mir nicht ein...
aber vielleicht reicht es ja.


ransi