Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS (s. Josef 14.09., 10:48:30)

Betrifft: SVERWEIS (s. Josef 14.09., 10:48:30) von: Andrea
Geschrieben am: 15.09.2004 11:36:41

Hallo zusammen

Josef hat gestern die Frage gestellt, wie die Formel beim SVERWEIS aussehen muss, damit kein Wert erscheint, wenn die gesuchte Zelle nicht gefunden wird. Ich habe nun ein ähnliches Problem. Wenn ich zum Beispiel die Formel
=SVERWEIS(A1;$G$1:$H$14;2;FALSCH) erfasse, erscheint ein #NV im Feld, wenn die Zelle nicht gefunden wird. Damit ich nun mit diesem Feld trotzdem rechnen kann, möchte ich, dass eine 0 anstelle der #NV erscheint. Wie kann ich dieses Problem lösen?

Vielen Dank im voraus für eure Hilfe.

Gruss
Andrea

  


Betrifft: AW: SVERWEIS (s. Josef 14.09., 10:48:30) von: Rudiator
Geschrieben am: 15.09.2004 11:38:36

Hai, probier mal:
=WENN(ISTFEHLER(SVERWEIS(A1;$G$1:$H$14;2;FALSCH))=WAHR;0;SVERWEIS(A1;$G$1:$H$14;2;FALSCH) )

Gruss
Rudi


  


Betrifft: AW: SVERWEIS (s. Josef 14.09., 10:48:30) von: Andrea
Geschrieben am: 15.09.2004 11:40:56

Genial, vielen Dank für die rasche Hilfe!

Gruss
Andrea


  


Betrifft: AW: SVERWEIS (s. Josef 14.09., 10:48:30) von: Rudiator
Geschrieben am: 15.09.2004 11:47:43

Schitte bön ;o)


  


Betrifft: AW: SVERWEIS (s. Josef 14.09., 10:48:30) von: heikoS
Geschrieben am: 15.09.2004 11:48:13

Hallo Andrea,

wenn Du nur den #NV abfangen willst, kannst Du auch WENN(ISTNV();;) benutzen. Das =WAHR kannst Du weglassen, das ergibt sich bereits aus der Definition der Funktion WENN().


Gruß Heiko


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS (s. Josef 14.09., 10:48:30)"