Microsoft Excel

Herbers Excel/VBA-Archiv

Falsches Ergebnis

Betrifft: Falsches Ergebnis von: Ruwer
Geschrieben am: 16.09.2004 10:42:36

Ich danke schon mal für eure Antworten.
Aber wie löse ich folgendes Problem ?

Wenn in Zelle "B11" kein Text (Name) vorhanden ist, soll in Zelle "F11" eine Null erscheinen, bzw. auch in anderen Zellen, in denen kein Text vorhanden ist.
Falls ein Name vorhanden ist, wird das Ergebnis dargestellt.
Realisiert habe ich das mit folgender Formel, dank eurer Hilfe.
Das klappt auch soweit sehr gut.

=WENN(B11="";0;SVERWEIS(X11;$C$2:$E$7;3))

Wenn ich aber jetzt aus den Zellen F11-F40 den Mittelwert bilden will, wird mir ein falsches Ergebnis angezeigt. (=MITTELWERT(F11:F40)
Hier beeinflussen die vorhandenen Nullen (da keine Namen vorhanden) offensichtlich das Ergebnis. Ist auch logisch, da ja alle Zellen gezählt werden.

Nur wie kann ich das korrigieren ?

  


Betrifft: AW: Falsches Ergebnis von: Udo
Geschrieben am: 16.09.2004 10:47:12

Reagiere erstmal auf andere Fragen.

Udo


  


Betrifft: AW: Falsches Ergebnis von: Magic
Geschrieben am: 16.09.2004 10:47:41

Hallo Ruwer,

wie wärs mit:
=summe(f11:f40)/zählenwenn(F11:F40;">0")

Gruß
Michael


  


Betrifft: AW: Falsches Ergebnis von: Ruwer
Geschrieben am: 16.09.2004 11:57:55

Magic,

super, danke, hat sofort geklappt.


  


Betrifft: AW: Falsches Ergebnis von: Andre
Geschrieben am: 16.09.2004 10:52:52

Wenn keine Null in den Zellen stehen soll, geht´s auch mit deiner Formel:

=WENN(B11="";"";SVERWEIS(X11;$C$2:$E$7;3))

Gruß Andre


  


Betrifft: AW: Falsches Ergebnis von: Ruwer
Geschrieben am: 16.09.2004 12:00:22

Andre,

danke für deine bemühungen. magic hat mir auch schon geholfen.

gruß
werner


  


Betrifft: Danke für die Rückmeldung. Erledigt. o.T. von: Andre
Geschrieben am: 16.09.2004 12:15:23




 

Beiträge aus den Excel-Beispielen zum Thema "Falsches Ergebnis"