Microsoft Excel

Herbers Excel/VBA-Archiv

Einfachbestände in neuer Spalte einfügen

Betrifft: Einfachbestände in neuer Spalte einfügen von: Stephan
Geschrieben am: 16.09.2004 11:14:04

Hallo Forumsmitglieder,

ich habe ein Problem mit dem Herausfiltern von Einfachbeständen.

In Spalte A stehen 800 Telefonnummern, in Spalte B 1000 Telefonnummern. 800 von den Telefonnummern der Spalte B sind mit denen der Spalte A identisch, wobei sie nicht in den gleichen Zeilen stehen.

Wie kann ich mir nun in Spalte C automatisch die 200 neuen Telefonnummern anzeigen lassen ?

Viele Grüße

Stephan

  


Betrifft: AW: Einfachbestände in neuer Spalte einfügen von: Günther Oppold
Geschrieben am: 16.09.2004 12:19:03

Hallo Stephan:

mein Lösungsvorschlag
(in Spalte D: ARRAY-Formel: die geschweifte Klammer nicht eingeben, sondern die Formeleingabe abschließen mit Strg+Umsch+Enter)

Tabelle2
 ABCD
1  Hilfsspalte1 
265498798732146549826
3123456654987298721
49873216549826#NV 
5 1234563 
6 98721#NV 
Formeln der Tabelle
C2 : =VERGLEICH(B2;A:A;0)
D2 : {=WENN(ISTFEHLER(KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1));"";INDIREKT("B"&KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1)))}
C3 : =VERGLEICH(B3;A:A;0)
D3 : {=WENN(ISTFEHLER(KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1));"";INDIREKT("B"&KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1)))}
C4 : =VERGLEICH(B4;A:A;0)
D4 : {=WENN(ISTFEHLER(KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1));"";INDIREKT("B"&KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1)))}
C5 : =VERGLEICH(B5;A:A;0)
D5 : {=WENN(ISTFEHLER(KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1));"";INDIREKT("B"&KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1)))}
C6 : =VERGLEICH(B6;A:A;0)
D6 : {=WENN(ISTFEHLER(KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1));"";INDIREKT("B"&KKLEINSTE(WENN(ISTFEHLER(C$1:C$1000);ZEILE($1:$1000));ZEILE()-1)))}
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

  


Betrifft: Suuuper Günther - Herzlichen Dank ... von: Stephan
Geschrieben am: 16.09.2004 16:08:38

Deine Lösung funktioniert prima. Ich versuche vorsichtshalber aber garnicht erst die Formel zu verstehen.

Du hast mir viel Arbeit erspart, Danke nochmal ...

Gruß Stephan


 

Beiträge aus den Excel-Beispielen zum Thema "Einfachbestände in neuer Spalte einfügen"