Microsoft Excel

Herbers Excel/VBA-Archiv

Problem Problem

Betrifft: Problem Problem von: michael
Geschrieben am: 16.09.2004 13:56:25

Hallo Ihr,

ich komm da nicht weiter.

Blatt Daten:
In Spalte A1 bis a166 steht die Zimmernummern ( am Anfang stehen auch mehrere "0" untereinander)
In Spalte b die Namen. Z.B a14="104" b12 ="Zink"

Blatt Suchmaske:
Da gebe ich in f4 den Namen ein und dann soll in F12 die Zimmernummer erscheinen.

Problem mit dieser Formel =SVERWEIS(F4;Daten!A1:C166;1;1)

Es wird immer die Zimmernummer b21 angezeigt. Also immer der letzte Eintrag in Spalte A (A166)

Beispiel anbei. https://www.herber.de/bbs/user/10960.xls


Ich Flipp hier gleich aus!
Kann mir jemand helfen???

Gruß
Michael


  


Betrifft: AW: Problem Problem von: Mac4
Geschrieben am: 16.09.2004 14:01:56

Hallo Michael,

nimm statt Sverweis Index und Vergleich:
=INDEX(Daten!A:A;VERGLEICH(F4;Daten!B:B;0))

Marc


  


Betrifft: AW: Problem Problem von: Michael
Geschrieben am: 16.09.2004 14:24:17

Hallo Marc,

Vielen Dank für die Hilfe.

Jetzt funktioniert es einwandfrei.

Und ich probier da stundenlang rum :-(

Danke nochmal
Gruß
Michael


 

Beiträge aus den Excel-Beispielen zum Thema "Problem Problem"