Microsoft Excel

Herbers Excel/VBA-Archiv

Formatierung bzw. gerade/ungerade Vergleich

Betrifft: Formatierung bzw. gerade/ungerade Vergleich von: Daniel
Geschrieben am: 16.09.2004 15:23:11

Hallo zusammen,

heute habe ich ein Vergleichsproblem bzw. ein Formatierungsproblem.

Eigentlich möchte ich eine Tabelle fomatieren nach dem Schema, Zeile 1 neutral, Zeil 2 Farbe (z.B. grün), Zeile 3 neutral, Zeile 4 Farbe (gleiche wie aus Zeile 2 ... und so weiter. Also jede 2. Zeile formatiert.
Problem ist, wenn eine Zeile eingefügt wird, soll die Formatierung sich anpassen. Hat jemand eine Idee?

Mein Gedanke war, dies über bedingte Formatierung zu erledigen.
Eine Spalte einfügen und die Zahlen von 1 bis ... Tabellenende eintragen.
Vorteil dieser Zahlenreihe ist, sie besteht aus geraden und ungeraden Zahlen.
Eigentlich ein ideales Vergleichskriterium - ist Zahl gerade, dann formatiere Zeile grün.
Nun die 2. Frage, wie bekomme ich das hin?
Finde nur Rundungsformel, aber keine die mir sagt, es handelt sich um eine ganze Zahl (dividiere die Ausgangszahl durch 2 - dann erhalte ich entweder eine ganze Zahl = gerade, oder eben keine ganze Zahl (Kommazahl) = ungerade).

Wie kann ich das Problem bestmöglich lösen?

Danke für Eure Anregungen und Bemühungen schon mal im Vorraus (:

  


Betrifft: AW: Formatierung bzw. gerade/ungerade Vergleich von: Mike
Geschrieben am: 16.09.2004 15:33:57

=ZEILE()=2*RUNDEN(ZEILE()/2;0)


  


Betrifft: AW: Formatierung bzw. gerade/ungerade Vergleich von: Magic
Geschrieben am: 16.09.2004 15:36:51

Hallo Daniel,

- markiere die erste Zeile
- Format/Bedingte Formatierung

-Formel ist:
=WENN(REST(ZEILE(A1);2)=0;WAHR;FALSCH)
Gewünschte Farbe einstellen

fertig

Das Format der ersten Zeile jetzt mit dem Pinsel auf die gewünschte Zeilenzahl ausdehnen.

Gruß
Michael


  


Betrifft: AW: Formatierung bzw. gerade/ungerade Vergleich von: Reinhard
Geschrieben am: 16.09.2004 15:39:17

Hi Daniel,
markiere den gewünschten Bereich,
dann als Bedingte formatierung
=REST(ZEILE();2)=0
eingeben, Musterfarbe einstellen
Gruß
Reinhard


  


Betrifft: Danke euch, funktioniert viel besser als gedacht! von: Daniel
Geschrieben am: 16.09.2004 15:47:51

Danke euch, funktioniert viel besser als gedacht!


 

Beiträge aus den Excel-Beispielen zum Thema "Formatierung bzw. gerade/ungerade Vergleich"