Microsoft Excel

Herbers Excel/VBA-Archiv

Werte übertragen und festhalten

Betrifft: Werte übertragen und festhalten von: Payne
Geschrieben am: 17.09.2004 10:38:09

Es sieht so aus: Mein Tabellenblatt1 wird ständig in unregelmäßigen Abständen mit einer unbestimmten Zahl an Daten gefüttert und hat folgende Form

Datum .... Betrag 1 Betrag 2 ....
17.09.04 10.000 20.000
17.09.04 10.000 20.000
17.09.04 10.000 20.000
17.09.04 10.000 20.000
17.09.04 10.000 20.000
20.10.04 30.000 40.000
20.10.04 30.000 40.000
20.10.04 30.000 40.000
20.10.04 30.000 40.000
20.10.04 30.000 40.000

Summe 200.000 300.000

Diese Tabelle wird nach unten immer weiter ergänzt, wobei sich die Summe ändert!
In mein leeres Datenblatt würde ich jetzt gerne immer automatisch das aktuelle Datum des letzten Eintrags inkl. der unten angezeigten Summe übernehmen. D.h. füge ich jetzt eine neue Datenreihe mit neuen Beträgen ein, soll der letzte Datensatz z.B. 20.10.04 200.000 stehen bleiben und in der nächsten Zeile der neue Datensatz mit den neuen Daten und der neuen Summe auftauchen!
Geht das mit SUMMEWENN?

  


Betrifft: AW: Werte übertragen und festhalten von: Jan
Geschrieben am: 17.09.2004 11:36:39

Hi Payne,

Du hättest in Deinem alten Beitrag bleiben sollen!

Anbei mal ein Beispiel, wie ich das Problem mit SUMMEWENN lösen würde.

https://www.herber.de/bbs/user/10993.xls

In Deiner Ausgangstabelle habe ich die Gesamtsumme für jede Spalte über
die Spaltenüberschriften positioniert.


Jan


  


Betrifft: Neues Problem von: Payne
Geschrieben am: 17.09.2004 13:24:50

Guden Jan,
also an Deinen Vorschlag mit SUMMEWENN hatte ich schon gedacht gehabt, nur hatte ich andauernd einen Eingabefehler gehabt! Jetzt klappt's.
Kann ich eigentlich das Datum bei Eingabe automatisch in das leere Tabellenblatt übertragen? Das Problem besteht wie gesagt darin, dass ich das Datum bis zur Eingabe nicht weiss und auch nicht die Zeile des Eintrags kenne, da immer eine unbestimmte Anzahl an Werten eingegeben wird.
Am Ende will ich im Prinzip nur Daten in die Tabelle einfügen und automatisch auf dem anderen Blatt das Datum plus den Wert ausgegeben bekommen.

MAX


  


Betrifft: AW: Werte übertragen und festhalten von: heikoS
Geschrieben am: 17.09.2004 11:52:44

Hallo Payne,

wahrscheinlich schon, aber ich würd´s so machen: das Datum steht in A1: =SUMMENPRODUKT(($A$2:$A$11<=A1)*$C$2:$C$11)


Gruß Heiko


  


Betrifft: AW: Werte übertragen und festhalten von: Payne
Geschrieben am: 17.09.2004 12:24:32

Gut! Das Übertragen hat mit SUMMEWENN bzw. SUMMEPRODUKT geklappt! Kann man aber auch irgendwie das Datum entsprechend automatisch übertragen. Das Problem ist nämlich, dass ich nie weiss in welcher Zeile das aktuelle Datum auftauchen wird, da ich nicht weiss wieviel Einträge ich zu diesem Datum vornehmen muss. Auch weiss ich bis zum Zeitpunkt des Eintrags nicht das genaue Datum.
Im Prinzip müsste automatisch beim Eintippen das Datum übertragen werden.
Geht so etwas mit EXCEL?


  


Betrifft: =max($A$2:$A$11) ... von: heikoS
Geschrieben am: 17.09.2004 12:41:11

... und dann in einen Text umwandeln (Zelle aktivieren, F2, F9).


Gruß Heiko


 

Beiträge aus den Excel-Beispielen zum Thema "Werte übertragen und festhalten"