Microsoft Excel

Herbers Excel/VBA-Archiv

zählenWenn Vorname&Nachname in Zellen

Betrifft: zählenWenn Vorname&Nachname in Zellen von: Andy
Geschrieben am: 19.09.2004 22:12:56

Hallo,

Ich habe ein Problem mit folgender Formel:
ZÄHLENWENN(A1:C40;"*"&D1&"*")
Ich möchte mit dieser Formel zählen, wie oft ein Name, der in D1 steht, im eingestellten Bereich vorkommt. Der Name wird "Vorname Nachname" geschrieben.
Die Formel funktionert soweit ganz gut, nur sobald der Name ZWEIMAL in einer Zelle vorkommt, wird er nur einmal gezählt.
Kann mir jemand helfen, wie ich dieses Problem beseitigen kann.

Wäre sehr dankbar.

Gruß
Andy

  


Betrifft: AW: zählenWenn Vorname&Nachname in Zellen von: Boris
Geschrieben am: 19.09.2004 22:26:05

Hi Andy,

Ahctung: Groß- und kleinschreibung wird unterschieden.

 
 ABCDE
1Karl Meier  Karl Meier3
2Klaus Müller    
3 Karl Meier Karl Meier   
Formeln der Tabelle
E1 : =SUMMENPRODUKT(LÄNGE(A1:B3)-LÄNGE(WECHSELN(A1:B3;D1;)))/LÄNGE(D1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Grüße Boris
www.excelformeln.de - die Formelseite im www


  


Betrifft: Danke! von: Andy
Geschrieben am: 19.09.2004 22:58:50

Funktioniert!
Danke!

Gruß
Andy


 

Beiträge aus den Excel-Beispielen zum Thema "zählenWenn Vorname&Nachname in Zellen"