Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
524to528
524to528
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Wort suchen und zeilennummer ausgeben
29.11.2004 14:08:57
Tobias
Hallo zusammen
Ich suche in einem Tabellenblatt per SVERWEIS einen bestimmten Begriff. Jetzt will ich aber als Ergebnis nicht den gesuchten Begriff selbst oder ein Wert in den folgenden Spalten, sondern die Zeilennummer in der der gesuchte Begriff sich befindet. Gibts für dieses "Problem" eine Formel?
Vielen Dank

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wort suchen und zeilennummer ausgeben
29.11.2004 15:20:57
Heinz
Hallo Tobias,
so geht es:
Tabelle2
 ABC
1gesuchtesteht in Zeile:6
2   
3 das 
4 ist 
5 das 
6 gesuchte 
7 Wort 
Formeln der Tabelle
C1 : =VERGLEICH(A1;B:B;0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
Anzeige
AW: Wort suchen und zeilennummer ausgeben
Daniel
Ok, super, funktioniert.
In meinem Fall ist der Suchbegriff jedoch nur Teil des Zelleninhalts (eine vorher hineinkopierte beliebige Syntax). Ich möchte nun eine Funktion ausführen aber nur in jener Zeile, in der sich ein bestimmter Code befindet. Dafür muss ich irgendwie die Zeilennummer ausgeben können und um dies zu bewerkstelligen müsste Excel die Zelle nicht nur in einer Spalte suchen sondern die Zelle gleichzeitig auch durchsuchen.
Danke
AW: Wort suchen und zeilennummer ausgeben
29.11.2004 17:54:08
Tobias
Klappt bestens! Vielen Dank!

300 Forumthreads zu ähnlichen Themen


Hallo,
ich möchte in Excell mehrere Zelle suchen, die folgenden String in einer oder mehreren Zeilen enthalten: ----
Diese Zeilen möchte ich dann löschen. Nach diesem String sind noch weitere Zeichen vorhanden, die auch gelöscht werden sollen.
Weiß jemand wie ich am besten vorgehe?...
Anzeige

Nabend alle miteinander
In einer bestimmten Zeile suche ich den letzten Eintrag. Bis zu diesem soll gefaerbt werden. Mit diesem Code faerbe ich den ganzen Bereich, es soll aber nur bis zum letzten Eintrag in der Zeile gefaerbt werden. Da von links nach rechts gefaerbt.
Case Is = Cells...

Hi,
ich versuche folgendes in meine Datei einzubauen.
Tabelle 2 enthält Adressdaten und eine Infospalte. In diese Infospalte kann der Wert "S" oder der Wert "A" eingetragen werden.
In Tabelle 1 sind auch diverse Adressdaten gepflegt. Alle Adressen in Tabelle 1 sind auch in Tabelle 2...
Anzeige

Hallo,
Zur Situation
in einer Excelspalte (z.B. A) füge ich - aus einem anderen Programm - kopierte Zahlen ein. Excel schreibt die, in Spalte A, eingefügten Zahlen untereinander. In der Spalte B berechne ich dann den Mittelwert wie folgt: =SUMME(A2:A1872)/1871
Mein Problem
Weil...

Hallo VBAler,
wenn ich ein Array in der Form
treffer_n(n)
habe, gibt es da eine schnelle und einfache Möglichkeit zu prüfen, ob ein bestimmter Wert in diesem Array vorhanden ist, oder muss ich alle Werte per Schleife einzeln prüfen lassen?
Gruß
David

Hallo,
ich benötige etwas Hilfe, vermutlich für euch kein Problem:
in Zelle A1 möchte ich den Spaltenbuchstaben eintragen
in Zelle A2 möchte ich eine Zeilennummer eintragen
in Zelle A3 fehlt mir nun die Formel, mit der ich A1undA2 verbinden kann UND dann den Inhalt der Zelle aus...
Anzeige
Anzeige

Infobox zum Thema

EXCEL - Wort suchen und Zeilennummer ausgeben


Inhaltsverzeichnis

  1. Was ist die Aufgabe?
  2. Einsatzzweck
  3. Lösungsweg
  4. Beispiel
  5. Zusammenfassung

Was ist die Aufgabe?

Statt den Wert mit Hilfe des SVERWEIS zurückzugeben, soll die Zeilennummer des gefundenen Wertes zurückgegeben werden.


Einsatzzweck

Manchmal ist es nützlich, die Zeilennummer eines gefundenen Eintrags zu kennen, besonders wenn man die Zeilennummer für weitere Berechnungen oder als Referenz nutzen möchte.


Lösungsweg {#lösungsweg}

Für diese Aufgabe ist der SVERWEIS nicht optimal. Stattdessen können Sie die VERGLEICH-Funktion nutzen:

=VERGLEICH(Suchkriterium; Suchbereich; 0)

Die VERGLEICH-Funktion sucht nach einem Wert (das Suchkriterium) in einem Bereich (den Suchbereich) und gibt die relative Position dieses Wertes in dem Bereich zurück. Mit "0" als drittem Parameter stellen Sie sicher, dass nach einem genauen Treffer gesucht wird.


Beispiel

Angenommen, Sie haben in Spalte A die Werte:

A
1 Apfel
2 Banane
3 Orange
4 Zitrone

Und Sie möchten die Zeilennummer finden, in der "Orange" steht. Die Formel wäre:

=VERGLEICH("Orange"; A1:A4; 0)

Das Ergebnis wäre 3, da "Orange" in Zeile 3 steht.


Zusammenfassung

Wenn Sie die Zeilennummer eines bestimmten Wertes in einem Bereich finden möchten, verwenden Sie am besten die VERGLEICH-Funktion anstelle des SVERWEIS.

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige