Anzeige
Archiv - Navigation
556to560
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
556to560
556to560
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Nicht doppelte zahlen aus Ecxel Liste filtern

Nicht doppelte zahlen aus Ecxel Liste filtern
31.01.2005 09:06:22
schulze
Hallo,
ich habe eine laaaaaange Liste mit Zahlen. Aus dieser Liste sollen alle nicht doppelten Zahlen gelöscht werden (oder alle doppelten markiert werden...egal wie )
Über die ganzen Filter von Excel habe ich bisher keine Ergebnisse erzielt.
Wäre schön wenn mir jemand helfen könnte ;-)
Gruß
Ole

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Nicht doppelte zahlen aus Ecxel Liste filtern
Nike
Hi,
in der Spalte nebenan fuege die folgende Funktion ein
z.B. in B1
=zaehlenwenn(A:A;A1) (ich kann hier kein ae tippen)
dann filtere nach dem Wert 1 in dieser Spalte,
es gibt den Wert dann nur ein Mal in der Liste...
Bye
Nike
AW: Nicht doppelte zahlen aus Ecxel Liste filtern
31.01.2005 11:35:19
schulze
Sorry, bin mathematischer DAU und bekomme nicht das hin was ich möchte
also, ich habe eine ellenlange Liste (2000 Einträge Artikelnummern) mit jeweils drei dazu gehörigen Spalten (Artikelbeschreibung, Hersteller und Preis)
Ich habe 2 Listen (aus zwei verschiedenen Märkten) jeweils unterschiedlich gefärbt. Ich lege beide listen in eine Datei und sortiere nach Artikelnummern. Jetzt stehen gleiche Artikelnummer aus beiden Märkten untereinander und ich kan die Preise vergleichen. Aber es stehen noch unzählige Nummern dazwischen die jeweils nur an einer Verkaufsstelle vorhanden sind. Genau die -also die nicht doppelten- möche ich mitsamt ihrer drei dazugehörigen Spalten entfernen. Kann mir jemand ne Dau Anleitung geben um das umzusetzen?
thx
ole
Anzeige
mit Hilfsspalte
Günther
Hallo Ole
Vergleiche in jeder Tabelle in einer Hilfsspalte, ob die Artikel-Nr. in der 2. Tabelle enthalten ist.
Dann sortiere jede Tabelle 1. nach der Hilfsspalte 2. nach der Artikel-Nr.
Tabelle1
 ABCD
1ArtikelPreisMarktHilfsspalte
2Artikel1 5,00 € Markt A1
3Artikel2 6,00 € Markt A9
4Artikel3 7,00 € Markt A1
5Artikel4 8,00 € Markt A9
6Artikel5 9,00 € Markt A1
7Artikel6 10,00 € Markt A9
8Artikel7 11,00 € Markt A1
9Artikel8 12,00 € Markt A9
10Artikel9 13,00 € Markt A1
11Artikel10 14,00 € Markt A9
Formeln der Tabelle
D2 : =WENN(NICHT(ISTFEHLER(VERGLEICH(A2;F$2:F$11;0)));1;9)
 
Tabelle1
 FGHI
1ArtikelPreisMarktHilfsspalte
2Artikel1 6,00 € Markt B1
3Artikel3 7,00 € Markt B1
4Artikel5 8,00 € Markt B1
5Artikel7 9,00 € Markt B1
6Artikel9 10,00 € Markt B1
7Artikel11 11,00 € Markt B9
8Artikel13 12,00 € Markt B9
9Artikel15 13,00 € Markt B9
10Artikel17 14,00 € Markt B9
11Artikel19 15,00 € Markt B9
Formeln der Tabelle
I2 : =WENN(NICHT(ISTFEHLER(VERGLEICH(F2;A$2:A$11;0)));1;9)
 
Günther
Anzeige
AW: mit Hilfsspalte
01.02.2005 08:53:10
schulze
Hallo,
super Dank für die Hilfe. Diese Lösung scheint wohl die richtige zu sein funzt aber net so richtig bei mir (liegt wohl an mir...)
Habe meine Tabelle umkgebaut und die Spalte "D" leer gelassen , eine weitere Spalte eingefügt "e" und in diese die Formel kopiert (modifiziert auf die Menge meiner Artikel = D2 : =WENN(NICHT(ISTFEHLER(VERGLEICH(A2;F$2:F$2500;0)));1;9) ).
Jetzt müsste Excel ja, -wenn ich das richtig verstanden habe in Spalte "D" den Wert 9 oder 1 einsetzen, je nach dem wie der Vergleich mit Spalte "F" ausgegangen ist. Oder?
In Spalte "D" erscheint aber nichts und in Spalte "E" bleibt die Forlmel auch in Reinschrift zu erkennen, so als ob Excel sie nicht annimmt.
Für eine weitere Hilfe wäre ich äußerst dankbar.
thx
ole
Anzeige
AW: mit Hilfsspalte
Günther
Hallo Schulze
hast Du tatsächlich in E2 reingeschrieben: = D2 : =WENN(NICHT(ISTFEHLER(VERGLEICH(A2;F$2:F$2500;0)));1;9)
das kann nicht funktionieren (eigentlich hätte sogar eine Fehlermeldung kommen müssen.
wenn Du die Werte in Spalte D haben willst, dann formatiere D2 als Standard und füge folgende Formel ein (Du kannst Sie kopieren:
=WENN(NICHT(ISTFEHLER(VERGLEICH(A2;F$2:F$2500;0)));1;9)
in dem Grünen Rahmen meiner Lösung steht:
Formeln der Tabelle
D2: = dies bedeutet dass diese Formel in D2 steht!
Günther

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige