Datum setzen

Bild

Betrifft: Datum setzen von: Thomas B
Geschrieben am: 04.02.2005 15:48:03

Hallo Leute,

ich habe ien Problem mit der Datumssetzerei. In A1 wird ein Datum eingetragen. In J7 soll dann das Datum des 1. des darauffolgenden Monats erscheinen. Aber ausgenommen von diese Formel soll der jeweilige erste des Monats sein.
Ich hoffe das das verständlich ist was ich will.
Ich habe leider keine rechte Vorstellung wie dieses ablaufen soll.

MFG Thomas

Bild


Betrifft: AW: Datum setzen von: Werner Oertli
Geschrieben am: 04.02.2005 15:55:17

Grüezi Thomas

=MONATSENDE(A1;0)+1

mit dieser Formel bekommst Du den Ersten des Folgemonats.

Aber ausgenommen von diese Formel soll der jeweilige erste des Monats sein, habe ich nicht ganz verstanden

Gruss Werner


Bild


Betrifft: AW: Datum setzen von: Thomas
Geschrieben am: 04.02.2005 15:59:42

Hallo Werner,
das mit dem ersten hat zu folge das der Wert dann nicht auf den 1 des folgemonat getzt werden brauch. Sprich er ist gleich( A1 01/02/05 dann in J7 auch 01/02/05 ab 02/02/05 dann folgemonat.)
Danke schon mal.

MFG Thomas


Bild


Betrifft: AW: Datum setzen von: Werner Oertli
Geschrieben am: 04.02.2005 16:04:26

Hallo Thomas

=WENN(Tag(A1)=1;A1;MONATSENDE(A1;0)+1)

Ansonsten die andern Mldungen noch beachten.

Gruss Werner


Bild


Betrifft: AW: Datum setzen von: Thomas B
Geschrieben am: 04.02.2005 16:14:29

Danke das hat geholfen.

Schönes WE


Bild


Betrifft: Danke für die Rückmeldung OT:-) von: Werner Oertli
Geschrieben am: 04.02.2005 16:21:04




Bild


Betrifft: AW: Datum setzen von: Lars
Geschrieben am: 04.02.2005 15:56:49

So sollte es gehen. (sage ich als nciht sooo erfahrener, lasse mich aber gern Korrigieren)


Sub Eintragen()
Dim i As Integer
i = Month(Date)
j = Year(Date)
Worksheets("Tabellenblatt").Cells(10, 7) = "01." & i & "." & j
End Sub



Bild


Betrifft: AW: Datum setzen von: Josef Ehrensberger
Geschrieben am: 04.02.2005 15:56:53

Hallo Thomas!

Ganz klar ist es zwar nicht, aber vielleicht so!

=WENN(TAG(A1)=1;A1;DATUM(JAHR(A1);MONAT(A1)+1;1))



Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Datum setzen von: Günther Oppold
Geschrieben am: 04.02.2005 15:57:01

Hi Thomas

meist Du so:
=wenn(Tag(A1)=1;"";Datum(Jahr(A1);Monat(A1)+1;1))

Günther


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datum setzen"