Array-Formel / Zählenwenn

Bild

Betrifft: Array-Formel / Zählenwenn von: Erich M.
Geschrieben am: 05.02.2005 22:57:34

Hallo EXCEL-Freunde,

habe eine funktionierende Array-Formel:

Zahlen (2)
 ABCDE
1Zahl1234
2Anzahl849910095
3von / bis510  
Formeln der Tabelle
B2 : {=WENN(SUMME(ZÄHLENWENN(B$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(B$1;$B4:$U435));0)}
C2 : {=WENN(SUMME(ZÄHLENWENN(C$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(C$1;$B4:$U435));0)}
D2 : {=WENN(SUMME(ZÄHLENWENN(D$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(D$1;$B4:$U435));0)}
E2 : {=WENN(SUMME(ZÄHLENWENN(E$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(E$1;$B4:$U435));0)}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Ist es möglich, dass der Umfang der Zellen, der gezählt werden soll, variabel
bestimmt wird durch die Inhalte der Zellen in B3/C3 = die Zeilen, die gezählt werden
sollen. Das würde hier bedeuten: $B5:$U10.

Besten Dank für eine Hilfe!

mfg
Erich
http://www.toolex.de
Bild


Betrifft: AW: Array-Formel / Zählenwenn von: Ulf
Geschrieben am: 05.02.2005 23:00:01

Verwende die Funktion INDIREKT()

Ulf


Bild


Betrifft: ...fehlen meine Kenntnisse zum einbauen..o.T. von: Erich M.
Geschrieben am: 05.02.2005 23:08:25

.


Bild


Betrifft: AW: Array-Formel / Zählenwenn von: r.sch.
Geschrieben am: 05.02.2005 23:30:03

Hej Erich,
ersetze in der Matrixformel das Vorkommen (2x) des Bereichs ($B4:$U435) durch z. B.
indirekt(g1), wobei du dann in die Zelle g1 b4:c12 - oder eben den gewünschten Bereich - eingibst.

Gruß aus 'm Vorharz
Reinhard


Bild


Betrifft: AW: Array-Formel / Zählenwenn von: Erich M.
Geschrieben am: 06.02.2005 08:01:48

Hallo Reinhard,

besten Dank; zunächst klar.
Jetzt bastle ich noch daran, wie ich die Zeilen flexibel bekomme.
Die Spalten bleiben immer gleich.
Im nachstehenden Beispiel müsste quasi E3 und H3 flexibel sein; während D3 und G3
immer gleich bleibt:

Zahlen (2)
 ABCDEFGH
1Zahl1234567
2Anzahl1310095799878
3von / bisb4:u12 B5 U12
431.01.04       
502.02.0446824252728
603.02.048101115192731
704.02.0416192125263435
Formeln der Tabelle
B2 : {=WENN(SUMME(ZÄHLENWENN($B$1;INDIREKT($B3)))>0;SUMME(ZÄHLENWENN(B$1;INDIREKT($B3)));0)}
C2 : {=WENN(SUMME(ZÄHLENWENN($B$1;INDIREKT($B3)))>0;SUMME(ZÄHLENWENN(C$1;INDIREKT($B3)));0)}
D2 : {=WENN(SUMME(ZÄHLENWENN(D$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(D$1;$B4:$U435));0)}
E2 : {=WENN(SUMME(ZÄHLENWENN(E$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(E$1;$B4:$U435));0)}
F2 : {=WENN(SUMME(ZÄHLENWENN(F$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(F$1;$B4:$U435));0)}
G2 : {=WENN(SUMME(ZÄHLENWENN(G$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(G$1;$B4:$U435));0)}
H2 : {=WENN(SUMME(ZÄHLENWENN(H$1;$B4:$U435))>0;SUMME(ZÄHLENWENN(H$1;$B4:$U435));0)}
A5 : =WENN(WOCHENTAG(A4+1)=1;A4+2;A4+1)
A6 : =WENN(WOCHENTAG(A5+1)=1;A5+2;A5+1)
A7 : =WENN(WOCHENTAG(A6+1)=1;A6+2;A6+1)

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A41. / Formel ist =$BA4=MIN($BA$2:$BA$637)Abc
A42. / Formel ist =$AZ4=MAX($AZ$2:$AZ$637)Abc
A51. / Formel ist =$BA5=MIN($BA$2:$BA$637)Abc
A52. / Formel ist =$AZ5=MAX($AZ$2:$AZ$637)Abc
A61. / Formel ist =$BA6=MIN($BA$2:$BA$637)Abc
A62. / Formel ist =$AZ6=MAX($AZ$2:$AZ$637)Abc
A71. / Formel ist =$BA7=MIN($BA$2:$BA$637)Abc
A72. / Formel ist =$AZ7=MAX($AZ$2:$AZ$637)Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Besten Dank für eine Hilfe!

mfg
Erich
http://www.toolex.de


Bild


Betrifft: AW: Array-Formel / Zählenwenn von: r.sch.
Geschrieben am: 06.02.2005 14:12:17

Hej Erich,

setze zusammen:
in D3 steht dein B, in E3 steht 5, daraus machst du in einer weiteren Zelle (J1) =D3&E3. Genauso mit der 2. Adresse in einer weiteren Zelle (K1). Als Ergebnis:
=J1&":"&K1, jetzt kannst du die Zeilenzahl (E3) variieren.

Gruß aus 'm Vorharz
Reinhard


Bild


Betrifft: Danke - Reinhard; Problem gelöst - o.T. von: Erich M.
Geschrieben am: 06.02.2005 16:43:05

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Array-Formel / Zählenwenn"