leere zellen bei der Berechnung ignorieren

Bild

Betrifft: leere zellen bei der Berechnung ignorieren von: Schorsch
Geschrieben am: 11.02.2005 11:34:52

Tach auch,
tut mir echt leid, dass ich damit hier kommen muss, aber ich hab einfach null ahnung und komm da nicht weiter und das wurmt mich übelst!
Folgendes, ich möchte gerne, dass eine Formel bei der Berechnung die Zellen, die leer sind, ignoriert.
Hab da schon reichlich geforscht, aber ich schein irgendwie falsch zu suchen oder so, auf jeden Fall bin ich nicht fündig geworden!
Wäre sehr sehr nett wenn mir da jemand kurz weiterhelfen könnte, dann kann ich auch wieder schlafen ;)
MfG.: Schorsch

Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: HermannZ
Geschrieben am: 11.02.2005 11:39:40

Hallo Schorsch,

wäre echt nicht schlecht wenn du jetzt noch verraten würdest was wie wo gerechnet werden soll, dann könnte man dir auch ein Antwort auf deine Frage geben.

Gruß hermann


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: Schorsch
Geschrieben am: 11.02.2005 11:49:21

Tut mir leid, ich dachte das reicht so schon aus!
Es geht um die erstellung eines Spielplans (Fußball) von drei Mannnschaften, d.h. Mannschaft 1 gegen 2 und 1 gegen 3.
Ich habe eine Formel zur Berechnung der Punkte aufgestellt, die funktioniert auch einwandfrei, das problem ist nur, bei einem Remie gibts einen Punkt, wenn jetzt die leeren Zellen nicht ignoriert werden, dann hat jede Mannschaft, obwohl noch keine ergebnisse eingetragen sind zwei Punkte, weil Excel die leeren Zellen genauso behandelt, als wenn eine null dort stehen würde, also wie bei einem Spielergebnis 0:0
Wichtig ist natürlich, dass ich in der Formel nicht komplett die Zahl null außen vor lassen kann, weil es dann ja auch kein 0:0 mehr geben würde!
MfG.:Schorsch

P.S.: hier ist die Datei https://www.herber.de/bbs/user/17843.xls


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: HermannZ
Geschrieben am: 11.02.2005 12:03:44

Hallo Schorsch,

ich verstehe zwar nichts von solschen Tabellen aber ein versuch ist es wert,muss ja auch was lernen,
in L2 deine Formel leicht geändert =WENN(SUMME(B2:G2)=0;0;WENN(D2=E2;1;0)+WENN(F2=G2;1;0))

Gruß Hermann


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: Lars
Geschrieben am: 11.02.2005 12:08:57

Hi Schorsch
versuch das mal für dein L2 und folgende
Es kontrolliert vorher, ob das feld noch leer ist oder nicht. wenn leer, dann null, sonst nimmts deinen vergleich vor.
=WENN(D2="";0;WENN(D2=E2;1;0))+WENN(F2="";0;WENN(F2=G2;1;0))

Gruß Lars


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: Schorsch
Geschrieben am: 11.02.2005 12:23:33

Vielen, Dank, das war genau das was ich gesucht habe, hätte man eigentlich auch mal drauf kommen können, genau das is es, vielen Dank an euch beide für eure Mühen!
MfG.: Schorsch


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: Lars
Geschrieben am: 11.02.2005 12:10:56

Hi Hermann,
Bei dir klappts, es sei denn beide spiele gehen 0:0 aus, dann denkt deine zeile, dass noch nix passiert ist. dann hätten wir 2 unendschieden und eine 2, bei dir aber eine 0, weil die summe ja null ist

Gruß Lars


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: HermannZ
Geschrieben am: 11.02.2005 12:15:44

Hallo Lars,

ich sagte ja, von solschen Tabellen verstehe ich nichts und das meinte ich auch so.

Gruß HermannZ


Bild


Betrifft: AW: leere zellen bei der Berechnung ignorieren von: Lars
Geschrieben am: 11.02.2005 12:18:05

Hallo Herrmann,

war nciht böse gemeint, wollte es dir nur erklären. :) gibt halt bei unentschieden einen Punkt und auch ein 0:0 ist ein unentschieden.
Daher die Prüfung, ob überhaupt was eingetragen ist.
Schönes WE. :)

Gruß Lars


Bild


Betrifft: AW: Danke für die Erklärung...oT. von: HermannZ
Geschrieben am: 11.02.2005 12:34:17

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema "leere zellen bei der Berechnung ignorieren"