Wochenende und Schicht gesondert addieren

Bild

Betrifft: Wochenende und Schicht gesondert addieren von: Olaf
Geschrieben am: 11.02.2005 11:44:20

Für mich 2 unlösbare Probleme:
1. Wenn in der Spalte B Sa oder So ist, soll in J die Gesamtarbeitszeit addiert werden wie bei allen Tagen, zugleich soll die Gesamtzeit dieser Tage aber noch seperat in der jeweiligen Zelle(Inkonvenienz,Spalte Q), addiert werden.

2. Wenn in der Spalte H die Zeit über 19:00 dauert, soll diese "Abendzeit" in der jeweiligen Zelle (Inkonvenienz,Spalte P), addiert werden, allerdings NICHT wenn in Spalte B Sa oder So ist.

Hoffe, ich habe es verständlich erklärt und danke Euch im Voraus.
Olaf S.

Userbild

Bild


Betrifft: AW: Wochenende und Schicht gesondert addieren von: UweN
Geschrieben am: 11.02.2005 15:08:33

Hallo Olaf,

das könnte ungefähr so gehen (ungetestet):

Ich gehe davon aus, daß in Spalte B tatsächlich "Sa" oder "So" als Text steht:
1. In Q12 schreibst Du: Wenn(Oder(B12="Sa";B12="So");J12;0)

Wenn in Spalte B jedoch ein Datum steht, dann mußt Du B12="Sa" durch folgendes ersetzen:
WOCHENTAG(B12;2)=6

Für Sonntag:
WOCHENTAG(B12;2)=7

2. Vorschlag: den Vergleichswert 19:00 würde ich an Deiner Stelle in eine eigene Zelle schreiben; z.B. A2
Dann kommt in P12 diese Formel rein:
=WENN(UND(ODER(B12<>"Sa";B12<>"So");H12>$A$2);H12-$A$2;0)

Wenn in B12 ein Datum steht mußt Du auch hier die Funktion WOCHENTAG verwenden, um den Wochtentag des Datums zu ermitteln.
Wichtig sind auch die "$", wenn Du die Formeln runterkopierst.

Ich denke, das müßte so funktionieren (hab' nicht getestet).

viele Grüße
Uwe

P.S. Rückmeldung wäre nett !!!


Bild


Betrifft: KORREKTUR von: UweN
Geschrieben am: 11.02.2005 15:16:16

Hallo Olaf,

da war ein eben mindestens ein Fehler drin !!!!

Das:
=WENN(UND(ODER(B12<>"Sa";B12<>"So");H12>$A$2);H12-$A$2;0)
KANN NICHT FUNKTIONIEREN!

Versuch' es bitte so:
=WENN(ODER(B12="Sa";B12="So");0;WENN(H12>$A$2;H12-$A$2;0))

Viele Grüße
Uwe


Bild


Betrifft: AW: KORREKTUR von: Olaf
Geschrieben am: 11.02.2005 16:48:38

Wer immer Du bist - einfach genial. Funkt alles tip top! Ganz herzlichen Dank Uwe


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wochenende und Schicht gesondert addieren"