Hilfe beim Makro

Bild

Betrifft: Hilfe beim Makro
von: utz
Geschrieben am: 11.02.2005 14:48:21
Hi Ihr Excel Guru´s,
da hätte ich auch gleich mal ne Frage.

Ich bin an einer kl. Lagerexceldatei dran. Die wie Folgt aus aufgebaut ist.
Meine erste Tabelle heisst Artikel, dort hab ich in der Spalte A durchnummeriert von 1100-1179, in der Spalte B hab ich die Artikel Bezeichnung xyz eingetragen. Zusätzlich gibt es noch Spalte C(bestellen), Spalte D (Inventur-Bestand), Spalte E (mindest Bestand), Spalte F (Zugang) und Spalte G (Abgang). Die zweite Tabelle (Lagerbuchung) besteht aus Spalte A (ArtikelNr.), Spalte B (Bezeichnung, in der per =SVERWEIS(A2;Artikel!$A$2:$B$81;2) die Bezeichnung xyz aus Tab Artikel erschein) SpalteC (zugang), Spalte D (abgang).
Soweit zu dem vorhandenen, achso Excel 2002 wird benutz.
Jetzt hatte ich vor das wenn ich eine Artikelnr. eintrage und die Bezeichnung aus der Ersten Tabelle aufgerufen wird, ich anschliessend ein Wert in Zugang und ein Wert in Abgang eintrage, das per Befehlsschaltfläche ("jetzt buchen") ein makro ausgeführt wir welches die Wert C2 und D2 in meine erste Tabelle überträgt (nicht drüber kopiert, da ich damit noch rechnen will). Und das abhängig davon welchen Artikelnr. ich in A2 eingetragen habe. Abschliessend will ich nämlich noch ein paar Formel in Tabelle Artikel eintragen die mir den akt. Bestand oder zu bestellende Artikel anzeigen.
Über eine Antwort würde ich mich sehr freuen. Der code des makro wäre natürlich noch Hilfreicher.
danke schon mal im Voraus

Bild

Betrifft: AW: Hilfe beim Makro
von: Nike
Geschrieben am: 11.02.2005 15:42:24
Hi,
ohne Bsp Datei wird's schwierig...
Einfach nur Dummy Daten...
Bye
Nike
Bild

Betrifft: AW: Hilfe beim Makro
von: utz
Geschrieben am: 11.02.2005 17:40:27
Hier ist mein Datei, mit ein paar Beispiel Daten.
Bild

Betrifft: AW: Hilfe beim Makro
von: utz
Geschrieben am: 11.02.2005 19:16:34
Und noch einmal meine Datein
https://www.herber.de/bbs/user/17883.xls
Thx an Nike
Bild

Betrifft: AW: Hilfe beim Makro
von: Beni
Geschrieben am: 11.02.2005 21:40:30
Hallo Nike,
Gruss Beni


Sub buchen()
ArtNr = Cells(2, 1)
With Sheets("Artikel")
Set c = .Columns(1).Find(What:=ArtNr, LookIn:=xlValues, LookAt:=xlWhole)
If Not c Is Nothing Then
c(1, 6) = c(1, 6) + Cells(2, 3)
c(1, 7) = c(1, 7) + Cells(2, 4)
Cells(2, 3) = ""
Cells(2, 4) = ""
End If
End With
End Sub

Bild

Betrifft: AW: Hilfe beim Makro
von: PeterW
Geschrieben am: 11.02.2005 22:15:28
Hallo Beni,
Gruß
Peter
'magst du nicht mal anfangen, Variable zu dimensionieren?
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Probleme mit einer Formel (evtl. Datei zu gross?)"