Summenprodukt und Text = #WERT! ???

Bild

Betrifft: Summenprodukt und Text = #WERT! ??? von: Korl
Geschrieben am: 11.02.2005 15:45:17

Hallo,

ich habe mir folgende Funktion erstellt:

'=SUMMENPRODUKT((Art=M10)*($B$9:$B$373))

In dem Bereich "B9:B373" habe ich vereinzeln Text stehen und erhalte deswegen den Fehlerwert "#WERT!"

Die Funktion "Istfehler()" habe ich versucht in meine Formel einzubinden um trotzdem zum Ergebnis zu gelangen aber es gelingt mir nicht.

Besteht überhaupt eine Möglichkeit trotzdem zum Ergebnis zu kommen?

Kann mir bitte jemand helfen?

Gruß Korl

Bild


Betrifft: AW: Summenprodukt und Text = #WERT! ??? von: Günther Oppold
Geschrieben am: 11.02.2005 15:54:42

Hallo Korl

zusätzliche Abfrage: istzahl(B9:B373):

Tabelle1
 ABCD
1Art   
2M101 44
3M102  
4M103  
5M10ggg  
6M105  
7M106  
8M10ggg  
9M108  
10M109  
11M1010  
Formeln der Tabelle
D2 : =SUMMENPRODUKT((A2:A11="M10")*(ISTZAHL(B2:B11));(B2:B11))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

Bild


Betrifft: AW: Summenprodukt und Text = #WERT! ??? von: David
Geschrieben am: 11.02.2005 15:56:01

wie wärs mit einer zusätzlichen spalte neben spalte B, in der in jeder zeile folgende formel steht:

=wenn(istfehler(B1x1);0;B1)


Bild


Betrifft: AW: Summenprodukt und Text = #WERT! ??? von: Korl
Geschrieben am: 11.02.2005 16:29:41

Hallo Günther,

vielen Dank für den Tipp, klappt prima. Ich hätte ja auch selber darauf kommen müssen.


Hallo David,

auch Dir danke ich für Deine Mühe.

Gruß Korl


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Verzeichnis kopieren und umbenennen"