Gibt es eine umgekehrte Funktion DBSUMME?

Bild

Betrifft: Gibt es eine umgekehrte Funktion DBSUMME? von: Sascha
Geschrieben am: 14.02.2005 14:11:51

Hallo Allerseits!

Habe folgendes Problem:

Habe eine Reihe von Kraftfahrzeugen nach Spalten, d.h. jedes KFZ hat eine eigene Spalte für die Daten (Literverbrauch, Fahrleistung, Steuer, Versicherung usw.)

Nun habe ich in der Spalte auch ein Abteilungs- und Länderkennzeichen. Kann ich irgendwie Summenspalten nach Abteilungs- und Länderkennzeichen bilden???

D.h. Excel soll praktisch diejenigen Spalten aufaddieren welche in einer bestimmten Zeile ein bestimmtes Abteilungs- und Länderkennzeichen haben.

Ich habe es schon mittels DBSUMME versucht. Aber da kann man meines Wissens nur ein Datenbankfeld wählen und es wird die Summe der übereinstimmenden Zeilen gebildet. Eigentlich bräuchte ich die Funktion DBSUMME nur nach Spalten statt nach Zeilen.

Wer kann mir helfen? Danke bereits vorab!

Sascha

Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Hübi
Geschrieben am: 14.02.2005 14:16:52

Hi Sascha,

da könnte sich SUMMEWENN() anbieten.

Gruß Hübi


Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Sascha
Geschrieben am: 14.02.2005 14:20:36

Wow, das geht hier aber schnell. Danke erst mal für die schnelle Antwort.

Ich kenne den Befehl "ZÄHLENWENN". SUMMEWENN werde ich jetzt gleich mal ausprobieren.

Sascha


Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Hübi
Geschrieben am: 14.02.2005 14:30:19

Hi Sascha,

habe im anderen Posting die Formeln vergessen
Tabelle1
 ABCDEFGHIJ
1Länderkennung222333222444333222777Summe für222
2Kennzahl 1         
3Kennzahl 2         
4Kennzahl 31500700800600300400800 2700
5Kennzahl 4100200300400500600700 1000
Formeln der Tabelle
J4 : =SUMMEWENN($B$1:$H$1;J$1;B4:H4)
J5 : =SUMMEWENN($B$1:$H$1;J$1;B5:H5)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: Gibt es eine umgekehrte Funktion DBSUMME? von: Sascha
Geschrieben am: 14.02.2005 15:27:06

Hallo Hübi!

Es funktioniert!

Besten Dank für die Hilfe!!!

Sascha


Bild


Betrifft: Danke für die Antwort - erledigt o.T. von: Hübi
Geschrieben am: 14.02.2005 16:32:34




Bild


Betrifft: AW: Danke für die Antwort - erledigt o.T. von: Sascha
Geschrieben am: 14.02.2005 17:55:29

Dieses Forum ist wirklich genial. Ich habe mir damals die CD von Herrn Herber bestellt und muß hierzu sagen, daß diese eine echte Fundgrube für die Lösung täglich anstehender Probleme im Controlling sind.


Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Sascha
Geschrieben am: 14.02.2005 14:18:10

Tabellenbeispiel

Länderkennung 222 333 222 444 333 222 777 Summe222
Kennzahl 1
Kennzahl 2
Kennzahl 3 1500 700 800 600 300 400 800 2700
Kennzahl 4

So sieht die Tabelle in etwa aus (verknüpft mit einer Olap-Datenbank). Nun bräuchte ich für die Verdichtungen die Summen. Gibt es einen ähnlichen Befehl wie DBSUMME der den Wert 2700 mit dem Suchkriterium "222" liefert und den Wert 1000 für das Suchkriterium "333"???


Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Hübi
Geschrieben am: 14.02.2005 14:28:16

Hi Sascha,

meinst du es so
Tabelle1
 ABCDEFGHIJ
1Länderkennung222333222444333222777Summe für222
2Kennzahl 1         
3Kennzahl 2         
4Kennzahl 31500700800600300400800 2700
5Kennzahl 4100200300400500600700 1000
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Sascha
Geschrieben am: 14.02.2005 15:00:45

Hi Hübi!

Ja genau so! :-) Wollte hinter die Auflistung der einzelnen Kraftfahrzeuge sozusagen die "Bereichssummen" bilden. D.h. ich bräuchte die Summe für 222 und 333 sowie 444 usw. Bei mir in Excel sind es etwa 150 Fahrzeuge in etwa 12 bis 13 Bereichen.

Danke schon mal vorab für deine Bemühungen!

Viele Grüße,
Sascha


Bild


Betrifft: AW: Gibt es eine umgekehrte Funktion DBSUMME? von: Hübi
Geschrieben am: 14.02.2005 15:10:12

Hi Sascha,

meinst du so
Tabelle1
 ABCDEFGHIJKLM
1Länderkennung222333222444333222777Summe für222333444777
2Kennzahl 1        0000
3Kennzahl 2        0000
4Kennzahl 31500700800600300400800 27001000600800
5Kennzahl 4100200300400500600700 1000700400700
Formeln der Tabelle
J2 : =SUMMEWENN($B$1:$H$1;J$1;$B2:$H2)
K2 : =SUMMEWENN($B$1:$H$1;K$1;$B2:$H2)
L2 : =SUMMEWENN($B$1:$H$1;L$1;$B2:$H2)
M2 : =SUMMEWENN($B$1:$H$1;M$1;$B2:$H2)
J3 : =SUMMEWENN($B$1:$H$1;J$1;$B3:$H3)
K3 : =SUMMEWENN($B$1:$H$1;K$1;$B3:$H3)
L3 : =SUMMEWENN($B$1:$H$1;L$1;$B3:$H3)
M3 : =SUMMEWENN($B$1:$H$1;M$1;$B3:$H3)
J4 : =SUMMEWENN($B$1:$H$1;J$1;$B4:$H4)
K4 : =SUMMEWENN($B$1:$H$1;K$1;$B4:$H4)
L4 : =SUMMEWENN($B$1:$H$1;L$1;$B4:$H4)
M4 : =SUMMEWENN($B$1:$H$1;M$1;$B4:$H4)
J5 : =SUMMEWENN($B$1:$H$1;J$1;$B5:$H5)
K5 : =SUMMEWENN($B$1:$H$1;K$1;$B5:$H5)
L5 : =SUMMEWENN($B$1:$H$1;L$1;$B5:$H5)
M5 : =SUMMEWENN($B$1:$H$1;M$1;$B5:$H5)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: erledigt o.T. von: Hübi
Geschrieben am: 14.02.2005 16:33:48




Bild


Betrifft: Perfekt! Vielen Dank o.T. von: Sascha
Geschrieben am: 14.02.2005 17:56:20




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Gibt es eine umgekehrte Funktion DBSUMME?"