Verschachtelung

Bild

Betrifft: Verschachtelung von: Kevin
Geschrieben am: 14.02.2005 21:48:38

Hallo,

ich will eine Zeiterfassung mittels Tabelle lösen, bekomme aber das nicht hin, dass er die Ausnahme bei Wochenenden mitberücksichtigt.
Meine Tabelle: https://www.herber.de/bbs/user/18082.xls

Ich arbeite mit OpenOffice, kann also Excel spezifische Formeln nicht einbinden. Sonst bekomm ich eine Fehlermeldung.

Dann würde mich noch interessieren, ob es auch die Möglichkeit gibt mittels VBA etwas zu programmieren dass wenn ich auf das Datum klicke sich eine Eingabemaske aufmacht in welcher ich Beginn, 3 Pausen mit Start und Ende und die Gehtzeit eingeben kann. Das ist aber nur zweitrangig.

Wichtig für mich ist, dass die Bedingung mit dem Wochenende korrekt verarbeitet wird.

Ich weiss auch, dass ich die Frage gestern schon mal gestellt hab. Wollte aber dennoch noch mal einen neuen Thread aufmachen und werde auch nur noch mich auf diesen beziehen.

Bild


Betrifft: AW: Verschachtelung von: Hübi
Geschrieben am: 14.02.2005 22:49:50

Hi Kevin,

... dass er die Ausnahme bei Wochenenden mitberücksichtigt.
Was meinst du damit?

Wenn du eine konkrete Anwort haben willst, musst du auch deine Frage so stellen, dass die Helfer sich in dein Projekt hineindenken können.

Gruß Hübi


Bild


Betrifft: AW: Verschachtelung von: Kevin
Geschrieben am: 15.02.2005 23:35:26

von Mo-Fr soll die Funktion prüfen, ob die gearbeitete Zeit mehr als 6 Stunden ist und dann automatisch 30 Minuten abziehen. Ansonsten nur die tatsächliche Pausenzeit.

Falls Sa oder So (eben Wochenende) soll nur die tatsächliche Pausenzeit abgezogen werden, da hier keine Prüfung für mehr als 6 Stunden notwendig ist.

Ich dachte das dies anhand der schon erstellten Formeln nachvollziehbar ist, welche aber ja leider nicht funktionieren. Irgendwo ist da immer noch der Wurm drin.

Vielen Dank für Eure Unterstützung


Bild


Betrifft: AW: Verschachtelung von: Hübi
Geschrieben am: 16.02.2005 00:00:24

Hi Kevin,

mit dieser Erklärung konnte ich nun was anfangen.
So sieht es jetzt aus
Zeiterfassung
 ABCDEFG
1Datum BeginnEndePauseArbeitszeitnach Abzug Pause
201.01.05Wochenende08:50:0015:10:0000:40:0006:20:0005:40:00
302.01.05Wochenende08:50:0015:10:0000:15:0006:20:0006:05:00
403.01.05Arbeitstag08:30:0014:00:0000:10:0005:30:0005:20:00
504.01.05Arbeitstag08:30:0015:05:0000:28:0006:35:0006:05:00
605.01.05Arbeitstag08:30:0015:05:0000:28:0006:35:0006:05:00
706.01.05Arbeitstag08:30:0015:06:0000:27:0006:36:0006:06:00
Formeln der Tabelle
B2 : =WENN(WOCHENTAG(A2;2)<6;"Arbeitstag";"Wochenende")
F2 : =D2-C2
G2 : =WENN(UND(WOCHENTAG(A2;2)<6;F2>0,25);F2-1/48;F2-E2)
B3 : =WENN(WOCHENTAG(A3;2)<6;"Arbeitstag";"Wochenende")
F3 : =D3-C3
G3 : =WENN(UND(WOCHENTAG(A3;2)<6;F3>0,25);F3-1/48;F3-E3)
B4 : =WENN(WOCHENTAG(A4;2)<6;"Arbeitstag";"Wochenende")
F4 : =D4-C4
G4 : =WENN(UND(WOCHENTAG(A4;2)<6;F4>0,25);F4-1/48;F4-E4)
B5 : =WENN(WOCHENTAG(A5;2)<6;"Arbeitstag";"Wochenende")
F5 : =D5-C5
G5 : =WENN(UND(WOCHENTAG(A5;2)<6;F5>0,25);F5-1/48;F5-E5)
B6 : =WENN(WOCHENTAG(A6;2)<6;"Arbeitstag";"Wochenende")
F6 : =D6-C6
G6 : =WENN(UND(WOCHENTAG(A6;2)<6;F6>0,25);F6-1/48;F6-E6)
B7 : =WENN(WOCHENTAG(A7;2)<6;"Arbeitstag";"Wochenende")
F7 : =D7-C7
G7 : =WENN(UND(WOCHENTAG(A7;2)<6;F7>0,25);F7-1/48;F7-E7)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Und hier noch deine Datei https://www.herber.de/bbs/user/18147.xls

Gruß Hübi


Bild


Betrifft: AW: Verschachtelung von: Kevin
Geschrieben am: 16.02.2005 01:43:07

Vielen Dank Hübi :)

ich habs zwar auf viel umständlichere Weise mittlerweile auch selbst geschafft, werde aber Deine Formel trotzdem verwenden da die mir einfach besser erscheint und ich ja auch was lernen will :)

Gibt es vielleicht jetzt auch noch die Möglichkeit, die Kommt und Geht Zeiten per VBA-Script einzufügen?
Ich dachte dabei an ein Fenster, dass aufgeht, wenn ich auf das Datum klicke. Es sollten dann folgende Eingabefelder vorhanden sein:
kommt
1. Pause von bis
2. Pause von bis
3. Pause von bis
geht

Aber wenns zuviel Arbeit ist, ist mir auch schon so geholfen :)

thx a lot

Kevin


Bild


Betrifft: AW: Verschachtelung von: Hübi
Geschrieben am: 16.02.2005 10:37:06

Hi Kevin,

freut mich, wenn´s endlich klappt.
Ich arbeite mit OpenOffice, kann also Excel spezifische Formeln nicht einbinden. Sonst bekomm ich eine Fehlermeldung.
Mit diesen zwei Sätzen hast du dir die Antwort zu VBA eigentlich schon selbst gegeben.
OpenOffice org "spricht" BASIC und nicht VBA.

Ich habe es ausprobiert: VBA-Code wird nicht übersetzt in BASIC-Code.

Vielleicht gibt es jemand, der dir das noch macht. Darum Frage noch offen.

Gruß Hübi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellwert bei Dubletten-Vorkommen auf Null stellen"