Zählenwenn/Summewenn Problem

Bild

Betrifft: Zählenwenn/Summewenn Problem von: c0bRa
Geschrieben am: 15.02.2005 13:35:26

hallöchen allesamt...

also...

mein problem lautet wie folgt...

ich habe eine auswertungstabelle, eine datentabelle und eine hilfstabelle.

in der datentabelle stehen die rohdaten, in der hilfstabelle werden die kriterien festgelegt und in der auswertung soll dann die anzahl derer drinstehen, die die angewählte gruppe haben UND in den bereich < 20 € fallen.

vorschläge wie "such nach zählenwenn/summewenn mit 2 kriterien" sind sinnlos, da ich da denk ich mal schon fast alle beiträge durchhabe. es geht trotzdem nicht...

hab zwar gedacht dass ich mit matrixformeln weiterkomme, aber excel sagt mir was anderes... bin echt für hilfe dankbar, da ich ohne die formel eigentlich das ganze projekt in die tonne treten kann...

hier noch die datei: https://www.herber.de/bbs/user/18121.xls

schonmal danke im voraus


c0bRa
Bild


Betrifft: AW: Zählenwenn/Summewenn Problem von: c0bRa
Geschrieben am: 15.02.2005 13:43:07

axo...

hier die formeln, welche ich schon durchhabe, sowohl normal als auch matrix:

=SUMMENPRODUKT(Daten!A:A=Hilfstabelle!$A$2*Daten!C2<Hilfstabelle!C2) liefert Fehler
=SUMMENPRODUKT((Daten!A:A=Hilfstabelle!$A$2)*(Daten!C2<Hilfstabelle!C2)) liefert Fehler
=ZÄHLENWENN(Daten!A:A;Hilfstabelle!$A$2)*ZÄHLENWENN(Daten!C:C;"<"&Hilfstabelle!C2) liefert falsches Ergebnis
=(Daten!A:A=Hilfstabelle!$A$2)*Daten!C:C<Hilfstabelle!$C$2 liefert Falsch normal und Fehler Matrix
=SUMME((Daten!A:A=Hilfstabelle!$A$2)*Daten!C:C<Hilfstabelle!$C$2) liefert falschen Wert normal und Fehler Matrix


Bild


Betrifft: Frage noch offen angehakt ;) von: c0bRa (oT)
Geschrieben am: 15.02.2005 13:43:51




Bild


Betrifft: AW: Zählenwenn/Summewenn Problem von: u_
Geschrieben am: 15.02.2005 13:48:33

Hallo,
SUMMENPRODUKT verträgt keine ganzen Spalten!
=SUMMENPRODUKT((Daten!$A$1:$A$1000=Hilfstabelle!$A$2)*(Daten!C2<Hilfstabelle!C2))

Gruß


Bild


Betrifft: AW: Zählenwenn/Summewenn Problem von: c0bRa
Geschrieben am: 15.02.2005 13:58:12

und wieso sagt mir das keiner? :P

jedenfalls funzts jetzt ;)

Vielen dank :))


Bild


Betrifft: AW: Zählenwenn/Summewenn Problem von: c0bRa
Geschrieben am: 15.02.2005 14:26:12

hab jetzt ein weiteres problem...

wenn ich deine formel nun mit werten aus daten!i1:i65535 multiplizieren will sagt er immer #NV
sprich:

=SUMMENPRODUKT((Daten!$A$2:$A$65535=Hilfstabelle!$A$2)*(Daten!$C$2:$C$65535<=Hilfstabelle!$C$2)*(Daten!$I$2:$I$65535))
ergibt keinen wert, was es eigentlich sollte, weil wenn
=SUMMENPRODUKT((Daten!$A$2:$A$65535=Hilfstabelle!$A$2)*(Daten!$C$2:$C$65535<=Hilfstabelle!$C$2))
funktioniert, wobei die beiden kriterien eh nur 0 oder 1 ergeben sollte er auch das dritte kriterium akzeptieren und mit 0 oder 1 malnehmen, was er aber nicht tut

oder steh ich schonwieder aufm schlauch?


c0bRa


Bild


Betrifft: erledigt owT ;) von: c0bRa
Geschrieben am: 15.02.2005 15:00:21

.oO Funktion ISTFEHLER() lässt grüßen in der Datentabelle :P

wenn #NV rein geht kommt auch #NV raus :P

ist toll wenn das auf dein letzten 2000 von 30000 datensätzen passiert *g*


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn/Summewenn Problem"