Ersten Wert über 0 in einer Spalte anzeigen lassen

Bild

Betrifft: Ersten Wert über 0 in einer Spalte anzeigen lassen von: Weber Edgar
Geschrieben am: 16.02.2005 21:40:50

Hallo Profis, ich bräuchte mal eure Hilfe bei einem leidigen Problem. Folgendes: Ich habe eine Spalte mit 10 Werten untereinander. Ich brauche nun alle Werte aus dieser Spalte, die größer Null sind. Diese Werte sollen nun in einer extra Spalte untereinander erscheinen. Soll heißen wenn in Zeile 1 eine Null steht und in Zeile 2 eine 3, dann soll in der extra Spalte in Zeile 1, die 3 stehen. Wenn in der nächste Zeile (3) ebenfalls eine Null steht und in Zeile 4 eine 9, dann soll in der Extra Spalte zuerst die 3 und dann die 9 stehen. Leider habe ich keinen blassen Schimmer, wie ich das bewerkstelligen kann. Ich konnte auch auf der Herber-CD und in der Recherche nichts finden. Geht das überhaupt, wenn ja, wäre ich für euere Hilfe sehr dankbar.

mfg. Eddy

Bild


Betrifft: AW: Ersten Wert über 0 in einer Spalte anzeigen la von: Uduuh
Geschrieben am: 16.02.2005 21:49:28

Hallo,
das geht doch mit Spezialfilter.

Gruß aus'm Pott
Udo



Bild


Betrifft: AW: Das war ja leider nichts ! von: Weber Edgar
Geschrieben am: 16.02.2005 22:51:10

Vielen Dank, aber auf diese Lösung wäre ich auch gekommen. Ich brauche eine Formel oder ein Makro. Es steht ja bereits in meiner Beschreibung, das ich die Werte in einer Extra Zeile brauche. Ich möchte dazu auch nicht das Teilergebnis eines Spezialfilters kopieren und einfügen. Wer ne Lösung hat, bitte melden. Vielen Dank !


Bild


Betrifft: AW: Das war ja leider nichts ! von: Hübi
Geschrieben am: 17.02.2005 00:54:22

Hi Edgar,

eine Formellösung mit Hilfsspalte
Tabelle1
 ABC
1QuelleHSZiel
2111
30 4
44317
50 55
60 3
7176 
8557 
938 
Formeln der Tabelle
B2 : =WENN(A2>0;ZEILE()-1;"")
C2 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A1))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A1))+1))
B3 : =WENN(A3>0;ZEILE()-1;"")
C3 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A2))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A2))+1))
B4 : =WENN(A4>0;ZEILE()-1;"")
C4 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A3))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A3))+1))
B5 : =WENN(A5>0;ZEILE()-1;"")
C5 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A4))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A4))+1))
B6 : =WENN(A6>0;ZEILE()-1;"")
C6 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A5))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A5))+1))
B7 : =WENN(A7>0;ZEILE()-1;"")
C7 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A6))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A6))+1))
B8 : =WENN(A8>0;ZEILE()-1;"")
C8 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A7))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A7))+1))
B9 : =WENN(A9>0;ZEILE()-1;"")
C9 : =WENN(ISTFEHLER(INDEX(A:A;KKLEINSTE(B:B;ZEILE(A8))+1));"";INDEX(A:A;KKLEINSTE(B:B;ZEILE(A8))+1))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Ist zum Denken schon zu spät - geht sicher auch eleganter

Gruß Hübi


Bild


Betrifft: Super Lösung, Danke !!! von: Weber Edgar
Geschrieben am: 17.02.2005 17:04:38

Hallo Hübi, vielen Dank für diese Super-Lösung. Eleganter muß es gar nicht sein, mir reicht diese Lösung 100%ig. Danke nochmal, bist ein Guter !

PS: Leider habe ich schon zu oft Lösungen bekommen, mit denen man rein gar nichts anfangen kann, so wie die, von deinem Vor(löser). Wenn die gar nichts schreiben würden, wäre es oft besser. Deshalb nochmals vielen Dank !

mfg. Eddy


Bild


Betrifft: Danke für die Antwort - erledigt m.T. von: Hübi
Geschrieben am: 17.02.2005 18:26:53

Hi Edgar,

danke für die Blumen.
Ich muss dir aber auch sagen, dass alle Helfer des Forums zu Hause sitzen und aus Freude am Spaß (kostenlos) hier Lösungsvorschläge / Lösungen unterbreiten.
Da kann es schon mal passieren, dass die RICHTIGE LÖSUNG "verfehlt" wird.

Manchmal ist es auch wirklich nicht einfach, sich in die Gedanken der Frager zu versetzen und deren Probleme zu verstehen.
Und nicht zu vergessen - viele Wege führen nach Rom (zum Ziel).

Gruß Hübi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Ersten Wert über 0 in einer Spalte anzeigen lassen"